summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/root-docs/ChangeLog11
-rw-r--r--app-doc/root-docs/files/root-docs-6.00.01-fillpatterns.patch30
-rw-r--r--app-doc/root-docs/files/root-docs-6.00.01-makehtml.patch55
-rw-r--r--app-doc/root-docs/metadata.xml5
-rw-r--r--app-doc/root-docs/root-docs-5.34.26.ebuild133
5 files changed, 230 insertions, 4 deletions
diff --git a/app-doc/root-docs/ChangeLog b/app-doc/root-docs/ChangeLog
index 0128cc915533..036d47beb6af 100644
--- a/app-doc/root-docs/ChangeLog
+++ b/app-doc/root-docs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-doc/root-docs
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/root-docs/ChangeLog,v 1.43 2014/11/11 18:58:47 bircoph Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/root-docs/ChangeLog,v 1.44 2015/03/02 08:25:14 bircoph Exp $
+
+*root-docs-5.34.26 (02 Mar 2015)
+
+ 02 Mar 2015; Andrew Savchenko <bircoph@gentoo.org> +root-docs-5.34.26.ebuild,
+ +files/root-docs-6.00.01-fillpatterns.patch,
+ +files/root-docs-6.00.01-makehtml.patch, metadata.xml:
+ Version bump (from science overlay).
11 Nov 2014; Andrew Savchenko <bircoph@gmail.com> metadata.xml:
Package is now directly maintained instead of proxy-maintaining.
diff --git a/app-doc/root-docs/files/root-docs-6.00.01-fillpatterns.patch b/app-doc/root-docs/files/root-docs-6.00.01-fillpatterns.patch
new file mode 100644
index 000000000000..e48a4f77568a
--- /dev/null
+++ b/app-doc/root-docs/files/root-docs-6.00.01-fillpatterns.patch
@@ -0,0 +1,30 @@
+diff --git a/core/base/doc/macros/fillpatterns.C b/core/base/doc/macros/fillpatterns.C
+index b0a5132..fca81c8 100644
+--- a/core/base/doc/macros/fillpatterns.C
++++ b/core/base/doc/macros/fillpatterns.C
+@@ -20,11 +20,11 @@ TCanvas * fillpatterns()
+
+ // Fixed patterns.
+ for (i=1; i<=5; i++) {
+- box(j++, 0.01, y-bh, 0.19, y);
+- box(j++, 0.21, y-bh, 0.39, y);
+- box(j++, 0.41, y-bh, 0.59, y);
+- box(j++, 0.61, y-bh, 0.79, y);
+- box(j++, 0.81, y-bh, 0.99, y);
++ box(j, 0.01, y-bh, 0.19, y); j++;
++ box(j, 0.21, y-bh, 0.39, y); j++;
++ box(j, 0.41, y-bh, 0.59, y); j++;
++ box(j, 0.61, y-bh, 0.79, y); j++;
++ box(j, 0.81, y-bh, 0.99, y); j++;
+ y = y-bh-db;
+ }
+
+@@ -55,7 +55,7 @@ TCanvas * fillpatterns()
+ return Pat;
+ }
+
+-box(Int_t pat, Double_t x1, Double_t y1, Double_t x2, Double_t y2)
++void box(Int_t pat, Double_t x1, Double_t y1, Double_t x2, Double_t y2)
+ {
+ // Draw an box using the fill pattern "pat" with the "pat" value
+ // written on top.
diff --git a/app-doc/root-docs/files/root-docs-6.00.01-makehtml.patch b/app-doc/root-docs/files/root-docs-6.00.01-makehtml.patch
new file mode 100644
index 000000000000..613468629a53
--- /dev/null
+++ b/app-doc/root-docs/files/root-docs-6.00.01-makehtml.patch
@@ -0,0 +1,55 @@
+diff --git a/Makefile b/Makefile
+index 600e8db..afad025 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1072,16 +1072,7 @@ $(ROOTPCH): $(ROOTCLINGSTAGE1DEP) $(ALLHDRS) $(CLINGETCPCH) $(ORDER_) $(ALLLIBS)
+
+ ifeq ($(BUILDX11),yes)
+ ifeq ($(BUILDASIMAGE),yes)
+-html: rootexecs postbin changelog releasenotes
+-ifneq ($(USECONFIG),FALSE)
+- @if [ "x`which root.exe`" != "x$(DESTDIR)$(BINDIR)/root.exe" ] \
+- || [ "`which root.exe`" -ot "bin/root.exe" ]; then \
+- echo 'ERROR: root.exe has not been installed by this build.'; \
+- echo ' Run "make install" before running "make html".'; \
+- exit 1; \
+- fi
+-endif
+- @$(MAKELOGHTML)
++html: compiledata releasenotes
+ @$(MAKEHTML)
+ else
+ html:
+diff --git a/build/unix/makehtml.sh b/build/unix/makehtml.sh
+index a94e790..8b4589d 100755
+--- a/build/unix/makehtml.sh
++++ b/build/unix/makehtml.sh
+@@ -1,16 +1,16 @@
+ #! /bin/sh
+
+ dir=`pwd`
+-ROOT=$dir/bin/root
++ROOT=root
+ cd tutorials
+ # we need tutorials/hsimple.root
+ if [ ! -f hsimple.root ]; then
+- $ROOT -n -l -b -q hsimple.C
++ $ROOT -n -l -b -q hsimple.C && exit 1
+ fi
+ cd tree
+ # we need tutorials/tree/cernstaff.root
+ if [ ! -f cernstaff.root ]; then
+- $ROOT -n -l -b -q cernbuild.C
++ $ROOT -n -l -b -q cernbuild.C || exit 1
+ fi
+ cd $dir
+
+@@ -20,7 +20,7 @@ echo ""
+
+ # To generate the full documentation, we do need to
+ # use the graphics engine, so do not use '-b'.
+-$ROOT -n -l <<makedoc
++$ROOT -n -l <<makedoc || exit 1
+ THtml h;
+ h.LoadAllLibs();
+ h.MakeAll();
diff --git a/app-doc/root-docs/metadata.xml b/app-doc/root-docs/metadata.xml
index 7bdad9e071e7..10a4d1cf50e3 100644
--- a/app-doc/root-docs/metadata.xml
+++ b/app-doc/root-docs/metadata.xml
@@ -12,7 +12,8 @@
</longdescription>
<use>
<flag name="api">Generate html API documentation</flag>
- <flag name="math">Downloads all math related documentation</flag>
- <flag name="metric">Default to A4 paper size and metric measurement</flag>
+ <flag name="http">Build HttpServer documentation</flag>
+ <flag name="math">Provide all math related documentation</flag>
+ <flag name="metric">Default to A4 paper size and metric measurement. Letter will be used otherwise</flag>
</use>
</pkgmetadata>
diff --git a/app-doc/root-docs/root-docs-5.34.26.ebuild b/app-doc/root-docs/root-docs-5.34.26.ebuild
new file mode 100644
index 000000000000..b2fde365a48c
--- /dev/null
+++ b/app-doc/root-docs/root-docs-5.34.26.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/root-docs/root-docs-5.34.26.ebuild,v 1.1 2015/03/02 08:25:14 bircoph Exp $
+
+EAPI=5
+
+ROOT_PN="root"
+ROOFIT_DOC_PV=2.91-33
+ROOFIT_QS_DOC_PV=3.00
+TMVA_DOC_PV=4.2.0
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EVCS_OFFLINE=yes # we need exactly the same checkout as root itself
+ EGIT_REPO_URI="http://root.cern.ch/git/root.git"
+ KEYWORDS=""
+else
+ SRC_URI="ftp://root.cern.ch/${ROOT_PN}/${ROOT_PN}_v${PV}.source.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${ROOT_PN}"
+fi
+
+inherit eutils multilib virtualx
+
+DESCRIPTION="Documentation for ROOT Data Analysis Framework"
+HOMEPAGE="http://root.cern.ch/drupal"
+SRC_URI="${SRC_URI}
+ math? (
+ http://tmva.sourceforge.net/docu/TMVAUsersGuide.pdf -> TMVAUsersGuide-v${TMVA_DOC_PV}.pdf
+ http://root.cern.ch/download/doc/RooFit_Users_Manual_${ROOFIT_DOC_PV}.pdf
+ http://root.cern.ch/drupal/sites/default/files/roofit_quickstart_${ROOFIT_QS_DOC_PV}.pdf )
+ api? (
+ ${HOMEPAGE}/sites/all/themes/newsflash/images/blue/root-banner.png
+ ${HOMEPAGE}/sites/all/themes/newsflash/images/info.png )"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="api +math +metric http"
+
+VIRTUALX_REQUIRED="api"
+
+DEPEND="
+ ~sci-physics/root-${PV}[X,graphviz,opengl]
+ app-text/pandoc
+ app-text/texlive
+ dev-haskell/pandoc-citeproc[bibutils]
+ media-fonts/dejavu
+ virtual/pkgconfig"
+RDEPEND=""
+
+DOC_DIR="/usr/share/doc/${ROOT_PN}-${PV}"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ # we need to force sci-physics/root checkout here
+ git-r3_checkout "${EGIT_REPO_URI}" "${WORKDIR}/${P}" "sci-physics/root/0"
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ use api && epatch \
+ "${FILESDIR}/${PN}-6.00.01-makehtml.patch" \
+ "${FILESDIR}/${PN}-6.00.01-fillpatterns.patch"
+ # prefixify the configure script
+ sed -i \
+ -e "s:/usr:${EPREFIX}/usr:g" \
+ configure || die "prefixify configure failed"
+}
+
+src_configure() {
+ # we need only to setup paths here, html docs doesn't depend on USE flags
+ if use api; then
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --etcdir="${EPREFIX}/etc/root" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)/${PN}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --tutdir="${EPREFIX}/usr/share/doc/${PF}/examples/tutorials" \
+ --testdir="${EPREFIX}/usr/share/doc/${PF}/examples/tests" \
+ --with-llvm-config="${EPREFIX}/usr/bin/llvm-config" \
+ --with-sys-iconpath="${EPREFIX}/usr/share/pixmaps" \
+ --nohowto
+ fi
+}
+
+src_compile() {
+ pdf_target=( primer users-guide )
+ local pdf_size=pdfa4
+ use metric || pdf_size=pdfletter
+ use math && pdf_target+=( minuit2 spectrum )
+ use http && pdf_target+=( HttpServer JSROOT )
+
+ for (( i=0; i<${#pdf_target[@]}; i++ )); do
+ emake -C documentation/"${pdf_target[i]}" "${pdf_size}"
+ done
+
+ if use api; then
+ # video drivers may want to access hardware devices
+ cards=$(echo -n /dev/dri/card* /dev/ati/card* /dev/nvidiactl* | sed 's/ /:/g')
+ [[ -n "${cards}" ]] && addpredict "${cards}"
+
+ ROOTSYS="${S}" Xemake html
+ # if root.exe crashes, return code will be 0 due to gdb attach,
+ # so we need to check if last html file was generated;
+ # this check is volatile and can't catch crash on the last file.
+ [[ -f htmldoc/tableDescriptor_st.html ]] || die "html doc generation crashed"
+ fi
+}
+
+src_install() {
+ insinto "${DOC_DIR}"
+
+ for (( i=0; i<${#pdf_target[@]}; i++ )); do
+ doins documentation/"${pdf_target[i]}"/*.pdf
+ done
+ unset pdf_target
+
+ use math && doins \
+ "${DISTDIR}/RooFit_Users_Manual_${ROOFIT_DOC_PV}.pdf" \
+ "${DISTDIR}/roofit_quickstart_${ROOFIT_QS_DOC_PV}.pdf" \
+ "${DISTDIR}/TMVAUsersGuide-v${TMVA_DOC_PV}.pdf"
+
+ if use api; then
+ # Install offline replacements for online messages
+ cp "${DISTDIR}"/{root-banner.png,info.png} htmldoc/ || die "cp failed"
+ # too large data to copy
+ dodir "${DOC_DIR}/html"
+ mv htmldoc/* "${ED}${DOC_DIR}/html/" || die
+ docompress -x ${DOC_DIR}/html
+ fi
+}