summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim/vim-7.1-r1.ebuild')
-rw-r--r--app-editors/vim/vim-7.1-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-editors/vim/vim-7.1-r1.ebuild b/app-editors/vim/vim-7.1-r1.ebuild
new file mode 100644
index 000000000000..d3429e629254
--- /dev/null
+++ b/app-editors/vim/vim-7.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-7.1-r1.ebuild,v 1.1 2007/05/14 10:16:09 pioto Exp $
+
+inherit vim
+
+VIM_VERSION="7.1"
+VIM_GENTOO_PATCHES="vim-${VIM_VERSION}-gentoo-patches-r1.tar.bz2"
+#VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unstable/unix/vim-${VIM_VERSION}.tar.bz2
+ mirror://gentoo/${VIM_GENTOO_PATCHES}"
+ #mirror://gentoo/${VIM_ORG_PATCHES}
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="Vim, an improved vi-style text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+ !minimal? ( ~app-editors/vim-core-${PV} )"
+RDEPEND="${RDEPEND}
+ !<app-editors/nvi-1.81.5-r4
+ !minimal? ( ~app-editors/vim-core-${PV} )"