summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/zoinks/zoinks-0.3.8-r1.ebuild')
-rw-r--r--app-editors/zoinks/zoinks-0.3.8-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-editors/zoinks/zoinks-0.3.8-r1.ebuild b/app-editors/zoinks/zoinks-0.3.8-r1.ebuild
new file mode 100644
index 000000000000..7123155e822e
--- /dev/null
+++ b/app-editors/zoinks/zoinks-0.3.8-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zoinks/zoinks-0.3.8-r1.ebuild,v 1.1 2005/01/05 12:24:46 genone Exp $
+
+inherit eutils
+
+DESCRIPTION="programmer's text editor and development environment"
+HOMEPAGE="http://zoinks.mikelockwood.com/"
+SRC_URI="http://zoinks.mikelockwood.com/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc ~amd64"
+IUSE="nls imlib"
+
+DEPEND="nls? ( sys-devel/gettext )
+ imlib? ( media-libs/imlib )
+ virtual/x11"
+
+src_compile() {
+ epatch ${FILESDIR}/xorg-library-configure.patch
+ econf \
+ `use_enable nls` \
+ `use_enable imlib` \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README INSTALL AUTHORS NEWS ChangeLog
+}