summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/uptimes/uptimes-2.3.ebuild')
-rw-r--r--app-emacs/uptimes/uptimes-2.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/uptimes/uptimes-2.3.ebuild b/app-emacs/uptimes/uptimes-2.3.ebuild
new file mode 100644
index 000000000000..7a47ef53d812
--- /dev/null
+++ b/app-emacs/uptimes/uptimes-2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/uptimes/uptimes-2.3.ebuild,v 1.1 2002/11/01 02:52:02 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Track and display emacs session uptimes."
+HOMEPAGE="http://www.davep.org/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50uptimes-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/uptimes.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}