summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/wanderlust/wanderlust-2.15.5_pre20071215.ebuild')
-rw-r--r--app-emacs/wanderlust/wanderlust-2.15.5_pre20071215.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/wanderlust/wanderlust-2.15.5_pre20071215.ebuild b/app-emacs/wanderlust/wanderlust-2.15.5_pre20071215.ebuild
new file mode 100644
index 000000000000..8579b063143a
--- /dev/null
+++ b/app-emacs/wanderlust/wanderlust-2.15.5_pre20071215.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/wanderlust/wanderlust-2.15.5_pre20071215.ebuild,v 1.1 2008/01/27 23:49:45 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Yet Another Message Interface on Emacsen"
+HOMEPAGE="http://www.gohome.org/wl/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="bbdb ssl"
+
+DEPEND=">=app-emacs/apel-10.6
+ virtual/flim
+ app-emacs/semi
+ bbdb? ( app-emacs/bbdb )
+ !app-emacs/wanderlust-cvs"
+
+SITEFILE=70wl-gentoo.el
+
+src_compile() {
+ use ssl && echo "(setq wl-install-utils t)" >> WL-CFG
+ emake || die "emake failed"
+ emake info || die "emake info failed"
+}
+
+src_install() {
+ emake \
+ LISPDIR="${D}${SITELISP}" \
+ PIXMAPDIR="${D}/usr/share/wl/icons" \
+ install || die "emake install failed"
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" wl \
+ || die "elisp-site-file-install failed"
+
+ insinto /usr/share/wl/samples/ja
+ doins samples/ja/*
+ insinto /usr/share/wl/samples/en
+ doins samples/en/*
+
+ doinfo doc/wl-ja.info doc/wl.info
+ dodoc BUGS* ChangeLog INSTALL* NEWS* README*
+}