summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20121202-r1.ebuild')
-rw-r--r--app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20121202-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20121202-r1.ebuild b/app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20121202-r1.ebuild
new file mode 100644
index 000000000000..de8e4b9f2220
--- /dev/null
+++ b/app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20121202-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20121202-r1.ebuild,v 1.1 2012/12/02 22:47:47 pacho Exp $
+
+EAPI=5
+inherit emul-linux-x86
+
+LICENSE="BSD MIT LGPL-3 SGI-B-2.0"
+
+KEYWORDS="-* ~amd64 ~amd64-linux"
+
+# https://bugs.gentoo.org/show_bug.cgi?id=445712
+SRC_URI="${SRC_URI} https://dev.gentoo.org/~pacho/emul-linux-x86-${PV}/glu-9.0.0.tbz2"
+
+DEPEND="app-admin/eselect-opengl
+ >=app-admin/eselect-mesa-0.0.9"
+RDEPEND=">=app-emulation/emul-linux-x86-xlibs-20100611
+ !<app-emulation/emul-linux-x86-xlibs-20100611
+ media-libs/mesa"
+
+src_prepare() {
+ emul-linux-x86_src_prepare
+ rm -f "${S}/usr/lib32/libGL.so" || die
+ rm -f "${S}/usr/lib32/libGL.so.1" || die
+}
+
+pkg_postinst() {
+ # Update GL symlinks
+ eselect opengl set --use-old || die
+ # And the same for mesa (bug #355393)
+ eselect mesa set 32bit --auto || die
+}