summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/uae')
-rw-r--r--app-emulation/uae/uae-0.8.23_pre20040129.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-emulation/uae/uae-0.8.23_pre20040129.ebuild b/app-emulation/uae/uae-0.8.23_pre20040129.ebuild
index 6e40ac11969d..792695d87cad 100644
--- a/app-emulation/uae/uae-0.8.23_pre20040129.ebuild
+++ b/app-emulation/uae/uae-0.8.23_pre20040129.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.23_pre20040129.ebuild,v 1.1 2004/02/09 09:54:04 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.23_pre20040129.ebuild,v 1.2 2004/02/09 10:55:02 dholm Exp $
MY_PV="0.8.23-20040129"
S="${WORKDIR}/${PN}-${MY_PV}"
@@ -18,6 +18,9 @@ DEPEND="X? ( virtual/x11 gtk? x11-libs/gtk+ ) :
sdl? media-libs/libsdl"
src_compile() {
+ ewarn "Compiling the CPU-core requires a substantial amount of RAM."
+ ewarn "Make sure that you have at least 512MB of RAM+SWAP available."
+
econf || die "./configure failed"
emake -j1 || die "emake failed"
@@ -29,7 +32,7 @@ src_install() {
docs/README docs/README.PROGRAMMERS docs/README.unix \
docs/translated/*
- emake install
+ emake install DESTDIR=${D}
insinto /usr/share/uae/amiga-tools
doins amiga/{*hack,trans*,uae*,*.library}