summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine/wine-1.1.34.ebuild')
-rw-r--r--app-emulation/wine/wine-1.1.34.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-emulation/wine/wine-1.1.34.ebuild b/app-emulation/wine/wine-1.1.34.ebuild
index 6dfe8d6abd4a..0171a4a5d778 100644
--- a/app-emulation/wine/wine-1.1.34.ebuild
+++ b/app-emulation/wine/wine-1.1.34.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.34.ebuild,v 1.1 2009/12/07 11:08:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.34.ebuild,v 1.2 2009/12/12 16:20:25 vapier Exp $
EAPI="2"
@@ -63,7 +63,6 @@ RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
scanner? ( media-gfx/sane-backends )
ssl? ( dev-libs/openssl )
png? ( media-libs/libpng )
- win64? ( >=sys-devel/gcc-4.4.0 )
!win64? ( amd64? (
truetype? ( >=app-emulation/emul-linux-x86-xlibs-2.1 )
X? (
@@ -84,6 +83,11 @@ DEPEND="${RDEPEND}
sys-devel/flex"
src_unpack() {
+ if [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]] ; then
+ use win64 && die "you need gcc-4.4+ to build 64bit wine"
+ fi
+einfo "$(gcc-major-version) * 100 + $(gcc-minor-version)"
+
if [[ ${PV} == "9999" ]] ; then
git_src_unpack
else