summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx-configtool/fcitx-configtool-0.4.7.ebuild')
-rw-r--r--app-i18n/fcitx-configtool/fcitx-configtool-0.4.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-i18n/fcitx-configtool/fcitx-configtool-0.4.7.ebuild b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.7.ebuild
new file mode 100644
index 000000000000..0b2901602dba
--- /dev/null
+++ b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx-configtool/fcitx-configtool-0.4.7.ebuild,v 1.1 2013/07/24 10:32:22 yngwin Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A GTK+ GUI configuration tool for fcitx"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="http://download.fcitx-im.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk +gtk3"
+REQUIRED_USE="|| ( gtk gtk3 )"
+
+RDEPEND=">=app-i18n/fcitx-4.2.8
+ dev-libs/glib:2
+ gtk? ( x11-libs/gtk+:2 )
+ gtk3? ( x11-libs/gtk+:3 )"
+DEPEND="${RDEPEND}
+ app-text/iso-codes
+ dev-libs/libunique:1
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable gtk GTK2)
+ $(cmake-utils_use_enable gtk3 GTK3)"
+ cmake-utils_src_configure
+}