summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/gato/gato-0.6.6.ebuild')
-rw-r--r--app-misc/gato/gato-0.6.6.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/app-misc/gato/gato-0.6.6.ebuild b/app-misc/gato/gato-0.6.6.ebuild
index 337840abc376..eca32c27be24 100644
--- a/app-misc/gato/gato-0.6.6.ebuild
+++ b/app-misc/gato/gato-0.6.6.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gato/gato-0.6.6.ebuild,v 1.5 2006/08/19 18:14:48 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gato/gato-0.6.6.ebuild,v 1.6 2007/07/21 20:03:01 vapier Exp $
+
+inherit autotools eutils
DESCRIPTION="An interface to the at UNIX command"
HOMEPAGE="http://www.arquired.es/users/aldelgado/proy/gato/"
@@ -11,16 +13,15 @@ SLOT="0"
KEYWORDS="~ppc ~x86"
IUSE=""
-RDEPEND="=x11-libs/gtk+-1*
+DEPEND="=x11-libs/gtk+-1*
sys-process/at"
-DEPEND="${RDEPEND}
- sys-devel/automake
- sys-devel/autoconf"
src_unpack() {
unpack ${A}
- cd "${S}/src"
- aclocal && autoheader && automake -a --foreign && autoconf || die "autotools failed"
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-perms.patch
+ cd "${S}"/src
+ eautoreconf
}
src_compile() {
@@ -30,8 +31,9 @@ src_compile() {
}
src_install() {
- make install.xpm PREFIX="${D}/usr" || die "install.xpm failed"
+ emake install.xpm PREFIX="${D}/usr" || die "install.xpm failed"
+ chmod a-x "${D}"/usr/share/gato/* # fperms doesnt glob
dodoc AUTHOR CHANGELOG README TODO
cd src
- make install DESTDIR="${D}" || die "install failed"
+ emake install DESTDIR="${D}" || die "install failed"
}