summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/wammu')
-rw-r--r--app-mobilephone/wammu/ChangeLog8
-rw-r--r--app-mobilephone/wammu/files/digest-wammu-0.173
-rw-r--r--app-mobilephone/wammu/wammu-0.16.ebuild4
-rw-r--r--app-mobilephone/wammu/wammu-0.17.ebuild35
4 files changed, 47 insertions, 3 deletions
diff --git a/app-mobilephone/wammu/ChangeLog b/app-mobilephone/wammu/ChangeLog
index 9731051d9960..a75297fbc516 100644
--- a/app-mobilephone/wammu/ChangeLog
+++ b/app-mobilephone/wammu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-mobilephone/wammu
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.14 2006/10/26 18:58:28 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.15 2006/11/15 21:01:16 mrness Exp $
+
+*wammu-0.17 (15 Nov 2006)
+
+ 15 Nov 2006; Alin Nastac <mrness@gentoo.org> wammu-0.16.ebuild,
+ +wammu-0.17.ebuild:
+ Stable on x86. Version bump.
26 Oct 2006; Piotr Jaroszyński <peper@gentoo.org> wammu-0.16.ebuild:
Add pybluez dep for amd64 as pybluez is ~amd64 now.
diff --git a/app-mobilephone/wammu/files/digest-wammu-0.17 b/app-mobilephone/wammu/files/digest-wammu-0.17
new file mode 100644
index 000000000000..9584e49a9a08
--- /dev/null
+++ b/app-mobilephone/wammu/files/digest-wammu-0.17
@@ -0,0 +1,3 @@
+MD5 9964555a2b9e5ca4660da762883676d6 wammu-0.17.tar.bz2 236814
+RMD160 fd902dce7e0d115d58be17fa6ab29886b47bb52b wammu-0.17.tar.bz2 236814
+SHA256 3921c4df4d7d060f74480f1b869cf4a798103fb3b1a7704e510c6536f1631865 wammu-0.17.tar.bz2 236814
diff --git a/app-mobilephone/wammu/wammu-0.16.ebuild b/app-mobilephone/wammu/wammu-0.16.ebuild
index d00310b71ff3..6452dee0bdb7 100644
--- a/app-mobilephone/wammu/wammu-0.16.ebuild
+++ b/app-mobilephone/wammu/wammu-0.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/wammu-0.16.ebuild,v 1.2 2006/10/26 18:58:28 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/wammu-0.16.ebuild,v 1.3 2006/11/15 21:01:16 mrness Exp $
inherit distutils
@@ -10,7 +10,7 @@ SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc x86"
IUSE="bluetooth"
#gnome-bluetooth is used for additional functionality - see bug #101067
diff --git a/app-mobilephone/wammu/wammu-0.17.ebuild b/app-mobilephone/wammu/wammu-0.17.ebuild
new file mode 100644
index 000000000000..56c884c3da48
--- /dev/null
+++ b/app-mobilephone/wammu/wammu-0.17.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/wammu-0.17.ebuild,v 1.1 2006/11/15 21:01:16 mrness Exp $
+
+inherit distutils
+
+DESCRIPTION="front-end for gammu (Nokia and other mobiles)"
+HOMEPAGE="http://www.cihar.com/gammu/wammu/"
+SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="bluetooth"
+
+#gnome-bluetooth is used for additional functionality - see bug #101067
+RDEPEND=">=dev-python/wxpython-2.6
+ >=dev-python/python-gammu-0.15
+ bluetooth? (
+ net-wireless/gnome-bluetooth
+ dev-python/pybluez
+ )"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+src_compile() {
+ # SKIPWXCHECK: else 'import wx' results in
+ # Xlib: connection to ":0.0" refused by server
+ SKIPWXCHECK=yes distutils_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS FAQ NEWS"
+ SKIPWXCHECK=yes distutils_src_install
+}