summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/koffice/koffice-1.5_beta1.ebuild')
-rw-r--r--app-office/koffice/koffice-1.5_beta1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/app-office/koffice/koffice-1.5_beta1.ebuild b/app-office/koffice/koffice-1.5_beta1.ebuild
new file mode 100644
index 000000000000..c4b5ac7bcfd1
--- /dev/null
+++ b/app-office/koffice/koffice-1.5_beta1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.5_beta1.ebuild,v 1.1 2006/02/09 03:12:24 carlo Exp $
+
+inherit kde
+
+RV="1.4.90"
+MY_P="koffice-${RV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="An integrated office suite for KDE, the K Desktop Environment."
+HOMEPAGE="http://www.koffice.org/"
+#SRC_URI="mirror://kde/stable/koffice-${PV}/src/${P}.tar.bz2"
+SRC_URI="mirror://kde/unstable/koffice-${PV/_/-}/src/${MY_P}.tar.bz2"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc mysql opengl postgres"
+
+RDEPEND=">=media-gfx/imagemagick-5.5.2
+ >=app-text/wv2-0.1.9
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ media-libs/libart_lgpl
+ dev-libs/libxml2
+ dev-libs/libxslt
+ sys-libs/readline
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-libs/libpqxx )
+ virtual/python
+ dev-lang/ruby
+ >=media-libs/lcms-1.12
+ >=app-text/libwpd-0.8.2
+ opengl? ( virtual/opengl virtual/glu )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig"
+
+# add blockers on split packages derived from this one
+for x in $(get-child-packages ${CATEGORY}/${PN}); do
+ DEPEND="${DEPEND} !${x}"
+ RDEPEND="${RDEPEND} !${x}"
+done
+
+need-kde 3.3
+
+# TODO: kword sql plugin needs Qt compiled with sql support
+# the dependency on python is needed for scripting support in kexi
+# and for kivio/kiviopart/kiviosdk.
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql) $(use_enable opengl gl)"
+
+ kde_src_compile
+ if use doc; then
+ make apidox || die
+ fi
+}
+
+src_install() {
+ kde_src_install
+ if use doc; then
+ make DESTDIR="${D}" install-apidox || die
+ fi
+
+ dodoc changes-*
+}