summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/install-mask/ChangeLog7
-rw-r--r--app-portage/install-mask/install-mask-9999.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/app-portage/install-mask/ChangeLog b/app-portage/install-mask/ChangeLog
index d73f6a6c78ba..c875e288c092 100644
--- a/app-portage/install-mask/ChangeLog
+++ b/app-portage/install-mask/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/install-mask
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/install-mask/ChangeLog,v 1.15 2012/12/09 23:11:33 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/install-mask/ChangeLog,v 1.16 2012/12/15 12:38:06 mgorny Exp $
+
+*install-mask-9999 (15 Dec 2012)
+
+ 15 Dec 2012; Michał Górny <mgorny@gentoo.org> +install-mask-9999.ebuild:
+ Import the live ebuild.
09 Dec 2012; Michał Górny <mgorny@gentoo.org> install-mask-0.0.2-r2.ebuild:
Enable python3.3.
diff --git a/app-portage/install-mask/install-mask-9999.ebuild b/app-portage/install-mask/install-mask-9999.ebuild
new file mode 100644
index 000000000000..16882ec743dd
--- /dev/null
+++ b/app-portage/install-mask/install-mask-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/install-mask/install-mask-9999.ebuild,v 1.1 2012/12/15 12:38:06 mgorny Exp $
+
+EAPI=4
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1
+
+#if LIVE
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+inherit git-2
+#endif
+
+DESCRIPTION="Handle INSTALL_MASK setting in make.conf"
+HOMEPAGE="https://bitbucket.org/mgorny/install-mask/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="app-portage/flaggie[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]"
+#if LIVE
+
+KEYWORDS=
+SRC_URI=
+#endif