summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash/bash-4.0_p38.ebuild')
-rw-r--r--app-shells/bash/bash-4.0_p38.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-shells/bash/bash-4.0_p38.ebuild b/app-shells/bash/bash-4.0_p38.ebuild
index 75d805434004..2713510b93a8 100644
--- a/app-shells/bash/bash-4.0_p38.ebuild
+++ b/app-shells/bash/bash-4.0_p38.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0_p38.ebuild,v 1.2 2011/02/06 17:21:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0_p38.ebuild,v 1.3 2011/05/16 10:36:26 nyhm Exp $
EAPI="1"
@@ -167,7 +167,9 @@ pkg_preinst() {
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.
local target=$(readlink "${ROOT}"/bin/sh)
- ln -sf "${target}" "${ROOT}"/bin/sh
+ local tmp=$(emktemp "${ROOT}"/bin)
+ ln -sf "${target}" "${tmp}"
+ mv -f "${tmp}" "${ROOT}"/bin/sh
fi
}