summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/enchant/enchant-1.5.0.ebuild')
-rw-r--r--app-text/enchant/enchant-1.5.0.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/app-text/enchant/enchant-1.5.0.ebuild b/app-text/enchant/enchant-1.5.0.ebuild
index 9ac27a659bee..b15ee8b1958c 100644
--- a/app-text/enchant/enchant-1.5.0.ebuild
+++ b/app-text/enchant/enchant-1.5.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/enchant/enchant-1.5.0.ebuild,v 1.1 2010/03/09 17:40:33 serkan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/enchant/enchant-1.5.0.ebuild,v 1.2 2010/04/06 16:14:09 abcd Exp $
-EAPI="1"
+EAPI="3"
inherit libtool confutils autotools
DESCRIPTION="Spellchecker wrapping library"
@@ -11,7 +11,7 @@ SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
IUSE="aspell +hunspell zemberek"
COMMON_DEPENDS=">=dev-libs/glib-2
@@ -30,7 +30,7 @@ pkg_setup() {
confutils_require_any aspell hunspell zemberek
}
-src_unpack() {
+src_prepare() {
unpack ${A}
cd "${S}"
# Fix for upstream bug #12305
@@ -41,13 +41,12 @@ src_unpack() {
eautoreconf
}
-src_compile() {
+src_configure() {
econf $(use_enable aspell) \
$(use_enable hunspell myspell) \
$(use_enable zemberek) \
--disable-ispell \
- --with-myspell-dir=/usr/share/myspell/
- emake || die "emake failed"
+ --with-myspell-dir="${EPREFIX}"/usr/share/myspell/
}
src_install() {