summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libpanelappletmm/ChangeLog11
-rw-r--r--dev-cpp/libpanelappletmm/files/libpanelappletmm-2.26.0-no-shlib.patch85
-rw-r--r--dev-cpp/libpanelappletmm/libpanelappletmm-2.26.0-r1.ebuild32
3 files changed, 127 insertions, 1 deletions
diff --git a/dev-cpp/libpanelappletmm/ChangeLog b/dev-cpp/libpanelappletmm/ChangeLog
index cdd0131b3bcd..0232b98e65c6 100644
--- a/dev-cpp/libpanelappletmm/ChangeLog
+++ b/dev-cpp/libpanelappletmm/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-cpp/libpanelappletmm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libpanelappletmm/ChangeLog,v 1.6 2011/03/29 06:12:41 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libpanelappletmm/ChangeLog,v 1.7 2011/04/04 18:54:30 pacho Exp $
+
+*libpanelappletmm-2.26.0-r1 (04 Apr 2011)
+
+ 04 Apr 2011; Pacho Ramos <pacho@gentoo.org>
+ +libpanelappletmm-2.26.0-r1.ebuild,
+ +files/libpanelappletmm-2.26.0-no-shlib.patch:
+ Following the change in gnome-panel, drop in-process support for bonobo
+ applets here too, upstream bug #642637 (bug #361927 by Marko D., patch by
+ Vuntz).
29 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
libpanelappletmm-2.26.0.ebuild:
diff --git a/dev-cpp/libpanelappletmm/files/libpanelappletmm-2.26.0-no-shlib.patch b/dev-cpp/libpanelappletmm/files/libpanelappletmm-2.26.0-no-shlib.patch
new file mode 100644
index 000000000000..497b6c33fdba
--- /dev/null
+++ b/dev-cpp/libpanelappletmm/files/libpanelappletmm-2.26.0-no-shlib.patch
@@ -0,0 +1,85 @@
+Index: libpanelappletmm-2.26.0/libpanelapplet/libpanelappletmm/factory.cc
+===================================================================
+--- libpanelappletmm-2.26.0.orig/libpanelapplet/libpanelappletmm/factory.cc
++++ libpanelappletmm-2.26.0/libpanelapplet/libpanelappletmm/factory.cc
+@@ -30,11 +30,6 @@ int factory_main_closure(const Glib::ust
+ return panel_applet_factory_main_closure(iid.c_str(), Applet::get_type(), closure);
+ }
+
+-Bonobo_Unknown shlib_factory_closure(const Glib::ustring& iid, PortableServer_POA poa, void * impl_ptr, GClosure * closure, CORBA_Environment * ev)
+-{
+- return panel_applet_shlib_factory_closure(iid.c_str(), Applet::get_type(), poa, impl_ptr, closure, ev);
+-}
+-
+ } // namespace Panel
+ } // namespace Gnome
+
+Index: libpanelappletmm-2.26.0/libpanelapplet/libpanelappletmm/factory.h
+===================================================================
+--- libpanelappletmm-2.26.0.orig/libpanelapplet/libpanelappletmm/factory.h
++++ libpanelappletmm-2.26.0/libpanelapplet/libpanelappletmm/factory.h
+@@ -83,13 +83,8 @@ bool applet_factory_callback(PanelApplet
+ template<class DerivedApplet>
+ int factory_main(const Glib::ustring& iid);
+
+-template<class DerivedApplet>
+-Bonobo_Unknown shlib_factory(const Glib::ustring& iid, PortableServer_POA poa, void* impl_ptr, const SlotFactory& slot, CORBA_Environment* ev);
+-
+ int factory_main_closure(const Glib::ustring& iid, GClosure *closure);
+
+-Bonobo_Unknown shlib_factory_closure(const Glib::ustring& iid, PortableServer_POA poa, void* impl_ptr, GClosure* closure, CORBA_Environment* ev);
+-
+
+ template<class DerivedApplet>
+ int factory_main(const Glib::ustring& iid)
+@@ -99,14 +94,6 @@ int factory_main(const Glib::ustring& ii
+ return panel_applet_factory_main( iid.c_str(), Applet::get_type(), SignalProxy_Factory::c_callback, &proxy);
+ }
+
+-template<class DerivedApplet>
+-Bonobo_Unknown shlib_factory(const Glib::ustring& iid, PortableServer_POA poa, void* impl_ptr, const SlotFactory& slot, CORBA_Environment* ev)
+-{
+- SignalProxy_Factory proxy( sigc::ptr_fun(&applet_factory_callback<DerivedApplet>) );
+-
+- return panel_applet_shlib_factory( iid.c_str(), Applet::get_type(), poa, impl_ptr, SignalProxy_Factory::c_callback, &proxy, ev);
+-}
+-
+ } // namespace Panel
+ } // namespace Gnome
+
+Index: libpanelappletmm-2.26.0/libpanelapplet/src/libpanelapplet_methods.defs
+===================================================================
+--- libpanelappletmm-2.26.0.orig/libpanelapplet/src/libpanelapplet_methods.defs
++++ libpanelappletmm-2.26.0/libpanelapplet/src/libpanelapplet_methods.defs
+@@ -371,31 +371,4 @@
+ )
+ )
+
+-(define-function panel_applet_shlib_factory
+- (c-name "panel_applet_shlib_factory")
+- (return-type "Bonobo_Unknown")
+- (parameters
+- '("const-char*" "iid")
+- '("GType" "applet_type")
+- '("PortableServer_POA" "poa")
+- '("gpointer" "impl_ptr")
+- '("PanelAppletFactoryCallback" "callback")
+- '("gpointer" "user_data")
+- '("CORBA_Environment*" "ev")
+- )
+-)
+-
+-(define-function panel_applet_shlib_factory_closure
+- (c-name "panel_applet_shlib_factory_closure")
+- (return-type "Bonobo_Unknown")
+- (parameters
+- '("const-char*" "iid")
+- '("GType" "applet_type")
+- '("PortableServer_POA" "poa")
+- '("gpointer" "impl_ptr")
+- '("GClosure*" "closure")
+- '("CORBA_Environment*" "ev")
+- )
+-)
+-
+
diff --git a/dev-cpp/libpanelappletmm/libpanelappletmm-2.26.0-r1.ebuild b/dev-cpp/libpanelappletmm/libpanelappletmm-2.26.0-r1.ebuild
new file mode 100644
index 000000000000..398a49c300cf
--- /dev/null
+++ b/dev-cpp/libpanelappletmm/libpanelappletmm-2.26.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libpanelappletmm/libpanelappletmm-2.26.0-r1.ebuild,v 1.1 2011/04/04 18:54:30 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit gnome2 eutils
+
+DESCRIPTION="C++ interface for gnome panel"
+HOMEPAGE="http://www.gtkmm.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-cpp/gconfmm-2.4
+ >=dev-cpp/glibmm-2.4:2
+ >=dev-cpp/gtkmm-2.4:2.4
+ || ( gnome-base/gnome-panel[bonobo] <gnome-base/gnome-panel-2.32 )
+ <gnome-base/gnome-panel-2.91.6"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-util/pkgconfig"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Following the change in gnome-panel, drop in-process support for bonobo applets here too, upstream bug #642637
+ epatch "${FILESDIR}/${P}-no-shlib.patch"
+}