summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/hyperdex')
-rw-r--r--dev-db/hyperdex/ChangeLog8
-rw-r--r--dev-db/hyperdex/hyperdex-1.4.2.ebuild47
-rw-r--r--dev-db/hyperdex/hyperdex-1.4.3.ebuild47
-rw-r--r--dev-db/hyperdex/hyperdex-1.4.4.ebuild (renamed from dev-db/hyperdex/hyperdex-1.4.0.ebuild)2
4 files changed, 8 insertions, 96 deletions
diff --git a/dev-db/hyperdex/ChangeLog b/dev-db/hyperdex/ChangeLog
index a40706700da5..869bbed0707e 100644
--- a/dev-db/hyperdex/ChangeLog
+++ b/dev-db/hyperdex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/hyperdex
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/ChangeLog,v 1.24 2014/08/26 09:42:59 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/ChangeLog,v 1.25 2014/09/01 03:53:23 patrick Exp $
+
+*hyperdex-1.4.4 (01 Sep 2014)
+
+ 01 Sep 2014; Patrick Lauer <patrick@gentoo.org> +hyperdex-1.4.4.ebuild,
+ -hyperdex-1.4.0.ebuild, -hyperdex-1.4.2.ebuild, -hyperdex-1.4.3.ebuild:
+ Bump
*hyperdex-1.4.3 (26 Aug 2014)
diff --git a/dev-db/hyperdex/hyperdex-1.4.2.ebuild b/dev-db/hyperdex/hyperdex-1.4.2.ebuild
deleted file mode 100644
index 03b0fe723d5d..000000000000
--- a/dev-db/hyperdex/hyperdex-1.4.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/hyperdex-1.4.2.ebuild,v 1.1 2014/08/25 06:31:05 patrick Exp $
-EAPI=5
-
-PYTHON_COMPAT=( python2_7)
-inherit eutils python-r1 autotools
-
-DESCRIPTION="A searchable distributed Key-Value Store"
-
-HOMEPAGE="http://hyperdex.org"
-SRC_URI="http://hyperdex.org/src/${P}.tar.gz
- http://dev.gentooexperimental.org/~patrick/autotools-java.tar"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-IUSE="+python"
-# need to add ruby and java useflags too
-
-DEPEND="dev-cpp/glog
- dev-cpp/sparsehash
- dev-libs/cityhash
- dev-libs/libpo6
- dev-libs/libe
- dev-libs/busybee
- dev-libs/popt
- dev-libs/replicant
- dev-libs/json-c"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- cp "${WORKDIR}/"*.m4 m4/
- sed -i -e 's~json/json.h~json-c/json.h~' configure.ac common/datatype_document.cc daemon/index_document.cc || die "Blergh!"
- eautoreconf
-}
-src_configure() {
- econf --disable-static \
- $(use_enable python python-bindings)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Failed to install"
- newinitd "${FILESDIR}/hyperdex.initd" hyperdex || die "Failed to install init script"
- newconfd "${FILESDIR}/hyperdex.confd" hyperdex || die "Failed to install config file"
- find "${D}" -name '*.la' -exec rm {} \; # bad buildsystem! bad!
-}
diff --git a/dev-db/hyperdex/hyperdex-1.4.3.ebuild b/dev-db/hyperdex/hyperdex-1.4.3.ebuild
deleted file mode 100644
index d58f76f7b510..000000000000
--- a/dev-db/hyperdex/hyperdex-1.4.3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/hyperdex-1.4.3.ebuild,v 1.1 2014/08/26 09:42:59 patrick Exp $
-EAPI=5
-
-PYTHON_COMPAT=( python2_7)
-inherit eutils python-r1 autotools
-
-DESCRIPTION="A searchable distributed Key-Value Store"
-
-HOMEPAGE="http://hyperdex.org"
-SRC_URI="http://hyperdex.org/src/${P}.tar.gz
- http://dev.gentooexperimental.org/~patrick/autotools-java.tar"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-IUSE="+python"
-# need to add ruby and java useflags too
-
-DEPEND="dev-cpp/glog
- dev-cpp/sparsehash
- dev-libs/cityhash
- dev-libs/libpo6
- dev-libs/libe
- dev-libs/busybee
- dev-libs/popt
- dev-libs/replicant
- dev-libs/json-c"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- cp "${WORKDIR}/"*.m4 m4/
- sed -i -e 's~json/json.h~json-c/json.h~' configure.ac common/datatype_document.cc daemon/index_document.cc || die "Blergh!"
- eautoreconf
-}
-src_configure() {
- econf --disable-static \
- $(use_enable python python-bindings)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Failed to install"
- newinitd "${FILESDIR}/hyperdex.initd" hyperdex || die "Failed to install init script"
- newconfd "${FILESDIR}/hyperdex.confd" hyperdex || die "Failed to install config file"
- find "${D}" -name '*.la' -exec rm {} \; # bad buildsystem! bad!
-}
diff --git a/dev-db/hyperdex/hyperdex-1.4.0.ebuild b/dev-db/hyperdex/hyperdex-1.4.4.ebuild
index 7e015935733b..d9ddbdf57a51 100644
--- a/dev-db/hyperdex/hyperdex-1.4.0.ebuild
+++ b/dev-db/hyperdex/hyperdex-1.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/hyperdex-1.4.0.ebuild,v 1.1 2014/07/29 07:31:24 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/hyperdex-1.4.4.ebuild,v 1.1 2014/09/01 03:53:23 patrick Exp $
EAPI=5
PYTHON_COMPAT=( python2_7)