summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/octopus/octopus-3.0.1.ebuild')
-rw-r--r--dev-db/octopus/octopus-3.0.1.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/dev-db/octopus/octopus-3.0.1.ebuild b/dev-db/octopus/octopus-3.0.1.ebuild
index ac518180c1c6..30c29f675add 100644
--- a/dev-db/octopus/octopus-3.0.1.ebuild
+++ b/dev-db/octopus/octopus-3.0.1.ebuild
@@ -1,32 +1,31 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/octopus/octopus-3.0.1.ebuild,v 1.1 2005/01/22 17:28:32 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/octopus/octopus-3.0.1.ebuild,v 1.1.1.1 2005/11/30 10:11:41 chriswhite Exp $
inherit java-pkg
MY_PV=${PV//./-}
MY_PV=${MY_PV/-/.}
-DESCRIPTION="A Java-based Extraction, Transformation, and Loading (ETL) tool. It
-may connect to any JDBC data sources and perform transformations defined in an
-XML file."
+DESCRIPTION="A Java-based Extraction, Transformation, and Loading (ETL) tool. It may connect to any JDBC data sources and perform transformations defined in an XML file."
SRC_URI="http://download.forge.objectweb.org/${PN}/${PN}-${MY_PV}.src.tar.gz
mirror://gentoo/${PN}-xmls-${PV}.tar.bz2"
HOMEPAGE="http://octopus.objectweb.org"
LICENSE="LGPL-2.1"
SLOT="3.0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 x86"
IUSE="doc jikes source"
-DEPEND=">=virtual/jdk-1.4
- jikes? ( >=dev-java/jikes-1.21 )
- source?( app-arch/zip )
- >=dev-java/ant-core-1.4
- >=app-arch/unzip-5.50-r1"
RDEPEND=">=virtual/jre-1.4
>=dev-java/xerces-2.6
>=dev-java/log4j-1.2.8
- >=dev-java/rhino-1.6.1
+ =dev-java/rhino-1.6*
>=dev-java/fop-0.20.5
>=dev-db/hsqldb-1.7.2.4"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}
+ jikes? ( >=dev-java/jikes-1.21 )
+ source? ( app-arch/zip )
+ >=dev-java/ant-core-1.4
+ >=app-arch/unzip-5.50-r1"
S=${WORKDIR}/${PN}-3.0/Octopus-src
@@ -50,7 +49,7 @@ src_compile() {
}
src_install() {
- dodoc ChangeLog.txt LICENSE.txt ReleaseNotes.txt
+ dodoc ChangeLog.txt ReleaseNotes.txt
cd ${S}/modules
java-pkg_dojar dist/*.jar