summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/msp430mcu/msp430mcu-20120514.ebuild')
-rw-r--r--dev-embedded/msp430mcu/msp430mcu-20120514.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-embedded/msp430mcu/msp430mcu-20120514.ebuild b/dev-embedded/msp430mcu/msp430mcu-20120514.ebuild
new file mode 100644
index 000000000000..ec898c7b8713
--- /dev/null
+++ b/dev-embedded/msp430mcu/msp430mcu-20120514.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430mcu/msp430mcu-20120514.ebuild,v 1.1 2012/05/17 03:09:28 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="MCU-specific data for MSP430 microcontrollers"
+HOMEPAGE="http://mspgcc.sourceforge.net"
+SRC_URI="mirror://sourceforge/mspgcc/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-20111205-install.patch
+}
+
+src_install() {
+ MSP430MCU_ROOT="${S}" ./scripts/install.sh "${D}/usr"
+}