summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/icedtea')
-rw-r--r--dev-java/icedtea/ChangeLog7
-rw-r--r--dev-java/icedtea/icedtea-6.1.10.4-r1.ebuild14
-rw-r--r--dev-java/icedtea/icedtea-7.2.0-r1.ebuild14
3 files changed, 20 insertions, 15 deletions
diff --git a/dev-java/icedtea/ChangeLog b/dev-java/icedtea/ChangeLog
index 6880e7002c64..f9b70479e42c 100644
--- a/dev-java/icedtea/ChangeLog
+++ b/dev-java/icedtea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/icedtea
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/ChangeLog,v 1.48 2011/11/18 11:01:45 sera Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/ChangeLog,v 1.49 2011/11/18 16:41:38 caster Exp $
+
+ 18 Nov 2011; Vlastimil Babka <caster@gentoo.org> icedtea-6.1.10.4-r1.ebuild,
+ icedtea-7.2.0-r1.ebuild:
+ Fix detection of parallel jobs from MAKEOPTS to handle all syntax variants.
+ Fixes bug #337827 and #389791. Using syntax from waf-utils.eclass
18 Nov 2011; Ralph Sennhauser <sera@gentoo.org> icedtea-6.1.10.4-r1.ebuild,
icedtea-7.2.0-r1.ebuild:
diff --git a/dev-java/icedtea/icedtea-6.1.10.4-r1.ebuild b/dev-java/icedtea/icedtea-6.1.10.4-r1.ebuild
index 57d65afb6ab9..e9cf0da6935d 100644
--- a/dev-java/icedtea/icedtea-6.1.10.4-r1.ebuild
+++ b/dev-java/icedtea/icedtea-6.1.10.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/icedtea-6.1.10.4-r1.ebuild,v 1.5 2011/11/18 11:01:47 sera Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/icedtea-6.1.10.4-r1.ebuild,v 1.6 2011/11/18 16:41:38 caster Exp $
# Build written by Andrew John Hughes (gnu_andrew@member.fsf.org)
# *********************************************************
@@ -189,12 +189,12 @@ src_configure() {
die "Install a GNU Classpath JDK (gcj-jdk, cacao)"
fi
- # OpenJDK-specific parallelism support.
- procs=$(echo ${MAKEOPTS} | sed -r 's/.*-j\W*([0-9]+).*/\1/')
- if [[ -n ${procs} ]] ; then
- config="${config} --with-parallel-jobs=${procs}";
- einfo "Configuring using --with-parallel-jobs=${procs}"
- fi
+ # OpenJDK-specific parallelism support. Bug #389791, #337827
+ # Implementation modified from waf-utils.eclass
+ # Note that "-j" is converted to "-j1" as the system doesn't support --load-average
+ local procs=$(echo -j1 ${MAKEOPTS} | sed -r "s/.*(-j\s*|--jobs=)([0-9]+).*/\2/" )
+ config="${config} --with-parallel-jobs=${procs}";
+ einfo "Configuring using --with-parallel-jobs=${procs}"
if use_zero ; then
config="${config} --enable-zero"
diff --git a/dev-java/icedtea/icedtea-7.2.0-r1.ebuild b/dev-java/icedtea/icedtea-7.2.0-r1.ebuild
index 79a44cb2afd0..e4536d25f8db 100644
--- a/dev-java/icedtea/icedtea-7.2.0-r1.ebuild
+++ b/dev-java/icedtea/icedtea-7.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/icedtea-7.2.0-r1.ebuild,v 1.12 2011/11/18 11:01:45 sera Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/icedtea-7.2.0-r1.ebuild,v 1.13 2011/11/18 16:41:38 caster Exp $
# Build written by Andrew John Hughes (gnu_andrew@member.fsf.org)
# *********************************************************
@@ -204,12 +204,12 @@ src_configure() {
die "Install a GNU Classpath JDK (gcj-jdk, cacao)"
fi
- # OpenJDK-specific parallelism support.
- procs=$(echo ${MAKEOPTS} | sed -r 's/.*-j\W*([0-9]+).*/\1/')
- if [[ -n ${procs} ]] ; then
- config="${config} --with-parallel-jobs=${procs}";
- einfo "Configuring using --with-parallel-jobs=${procs}"
- fi
+ # OpenJDK-specific parallelism support. Bug #389791, #337827
+ # Implementation modified from waf-utils.eclass
+ # Note that "-j" is converted to "-j1" as the system doesn't support --load-average
+ local procs=$(echo -j1 ${MAKEOPTS} | sed -r "s/.*(-j\s*|--jobs=)([0-9]+).*/\2/" )
+ config="${config} --with-parallel-jobs=${procs}";
+ einfo "Configuring using --with-parallel-jobs=${procs}"
if use_zero ; then
config="${config} --enable-zero"