summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/check/check-0.9.5.ebuild')
-rw-r--r--dev-libs/check/check-0.9.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/check/check-0.9.5.ebuild b/dev-libs/check/check-0.9.5.ebuild
new file mode 100644
index 000000000000..0c333af54e3e
--- /dev/null
+++ b/dev-libs/check/check-0.9.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/check/check-0.9.5.ebuild,v 1.1 2006/12/14 16:16:47 twp Exp $
+
+inherit autotools eutils libtool
+
+DESCRIPTION="A unit test framework for C"
+HOMEPAGE="http://sourceforge.net/projects/check/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ elibtoolize || die
+}
+
+src_compile() {
+ eautoreconf || die
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}