summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/distorm64/files/distorm64-1.7.30-respect_flags.patch')
-rw-r--r--dev-libs/distorm64/files/distorm64-1.7.30-respect_flags.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/distorm64/files/distorm64-1.7.30-respect_flags.patch b/dev-libs/distorm64/files/distorm64-1.7.30-respect_flags.patch
new file mode 100644
index 000000000000..0af2da2f7a9b
--- /dev/null
+++ b/dev-libs/distorm64/files/distorm64-1.7.30-respect_flags.patch
@@ -0,0 +1,42 @@
+--- build/linux/Makefile
++++ build/linux/Makefile
+@@ -6,7 +6,7 @@
+ COBJS = ../../src/x86defs.o ../../src/wstring.o ../../src/textdefs.o ../../src/prefix.o ../../src/operands.o ../../src/insts.o ../../src/instructions.o ../../src/distorm.o ../../src/decoder.o
+ PYOBJS = ../../src/x86defs.o ../../src/wstring.o ../../src/textdefs.o ../../src/pydistorm.o ../../src/prefix.o ../../src/operands.o ../../src/insts.o ../../src/instructions.o ../../src/decoder.o
+ CC = gcc
+-CFLAGS = -O2 -Wall -fPIC -DSUPPORT_64BIT_OFFSET -D_DLL
++CFLAGS += -Wall -fPIC -DSUPPORT_64BIT_OFFSET -D_DLL
+
+ all: clib py
+
+@@ -14,11 +14,11 @@
+ /bin/rm -rf ../../src/*.o ${TARGET} ../../distorm64.a
+
+ clib: ${COBJS}
+- ${CC} ${CFLAGS} ${VERSION} ${COBJS} -fPIC -shared -o ${TARGET}
++ ${CC} ${LDFLAGS} ${VERSION} ${COBJS} -fPIC -shared -o ${TARGET}
+ ar rs ../../distorm64.a ${COBJS}
+
+ py: ${PYOBJS}
+- ${CC} ${CFLAGS} ${VERSION} ${PYOBJS} -fPIC -shared -o ${TARGET}
++ ${CC} ${LDFLAGS} ${VERSION} ${PYOBJS} -fPIC -shared -o ${TARGET}
+
+ install: libdistorm64.so
+ install -s ${TARGET} /usr/local/lib
+--- linuxproj/Makefile
++++ linuxproj/Makefile
+@@ -4,12 +4,12 @@
+
+ TARGET = disasm
+ CC = gcc
+-CFLAGS = -Wall -O2 -I. -o
++CFLAGS += -Wall -I.
+
+ all: disasm
+
+ disasm:
+- ${CC} ${CFLAGS} ${TARGET} main.c ../distorm64.a
++ ${CC} ${CFLAGS} ${LDFLAGS} -o ${TARGET} main.c ../distorm64.a
+
+ clean:
+ /bin/rm -rf *.o ${TARGET}