summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libgcrypt/libgcrypt-1.2.2.ebuild')
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.2.2.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-libs/libgcrypt/libgcrypt-1.2.2.ebuild b/dev-libs/libgcrypt/libgcrypt-1.2.2.ebuild
deleted file mode 100644
index 00f6b108fbd2..000000000000
--- a/dev-libs/libgcrypt/libgcrypt-1.2.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.2.2.ebuild,v 1.5 2007/03/03 22:58:06 genone Exp $
-
-inherit eutils
-
-DESCRIPTION="general purpose crypto library based on the code used in GnuPG"
-HOMEPAGE="http://www.gnupg.org/"
-SRC_URI="mirror://gnupg/libgcrypt/${P}.tar.gz
- mirror://gentoo/${PN}-1.2.1-patches.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nls"
-
-DEPEND="dev-libs/libgpg-error"
-RDEPEND="nls? ( sys-devel/gettext )
- dev-libs/libgpg-error"
-
-src_unpack() {
- unpack ${A}
- epunt_cxx
-
- # fix for miss detection of 32 bit ppc
- cd ${S}
- epatch ${WORKDIR}/${PN}-1.2.1-ppc64-fix.patch
-
- cd ${S}
- epatch ${WORKDIR}/${PN}-1.2.1-GNU-stack-fix.patch
-}
-
-src_compile() {
- econf $(use ppc64) --disable-asm || die
- econf $(use_enable nls) --disable-dependency-tracking --with-pic || die
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS BUGS ChangeLog NEWS README* THANKS TODO VERSION
-
- # backwards compat symlinks
- dosym libgcrypt.so.11 /usr/lib/libgcrypt.so.7
-}