summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-png/cl-png-0.2.ebuild')
-rw-r--r--dev-lisp/cl-png/cl-png-0.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-lisp/cl-png/cl-png-0.2.ebuild b/dev-lisp/cl-png/cl-png-0.2.ebuild
new file mode 100644
index 000000000000..c64d703dddc8
--- /dev/null
+++ b/dev-lisp/cl-png/cl-png-0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-png/cl-png-0.2.ebuild,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Common Lisp package to read and write PNG image files"
+HOMEPAGE="http://www.pvv.ntnu.no/~musum/lisp/code/
+ http://www.cliki.net/PNG
+ http://packages.debian.org/unstable/devel/cl-png.html"
+SRC_URI="http://www.pvv.ntnu.no/~musum/lisp/code/png-${PV}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=png
+
+S=${WORKDIR}/png-${PV}
+
+src_install() {
+ common-lisp-install *.cl ${FILESDIR}/png.asd
+ common-lisp-system-symlink
+ dodoc COPYING README
+}