summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocamlgraph/ocamlgraph-0.81.ebuild')
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-0.81.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/ocamlgraph/ocamlgraph-0.81.ebuild b/dev-ml/ocamlgraph/ocamlgraph-0.81.ebuild
new file mode 100644
index 000000000000..8a00b5935f7b
--- /dev/null
+++ b/dev-ml/ocamlgraph/ocamlgraph-0.81.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ocamlgraph-0.81.ebuild,v 1.3 2006/02/04 22:25:39 mattam Exp $
+
+inherit findlib
+
+DESCRIPTION="O'Caml Graph library"
+HOMEPAGE="http://www.lri.fr/~filliatr/ocamlgraph/"
+SRC_URI="http://www.lri.fr/~filliatr/ftp/ocamlgraph/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+DEPEND=">=dev-lang/ocaml-3.08
+ doc? ( dev-tex/hevea dev-ml/ocamlweb )"
+IUSE="doc"
+
+src_compile() {
+ econf || die
+ emake || die
+
+ if use doc;
+ then
+ emake doc
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ make install-findlib || die
+
+ dodoc README COPYING CREDITS FAQ CHANGES
+ if use doc;
+ then
+ dohtml doc/*
+ fi
+}