summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-PEAR')
-rw-r--r--dev-php/PEAR-PEAR/ChangeLog10
-rw-r--r--dev-php/PEAR-PEAR/PEAR-PEAR-1.4.11.ebuild35
-rw-r--r--dev-php/PEAR-PEAR/PEAR-PEAR-1.5.1.ebuild146
-rw-r--r--dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.5.115
4 files changed, 186 insertions, 20 deletions
diff --git a/dev-php/PEAR-PEAR/ChangeLog b/dev-php/PEAR-PEAR/ChangeLog
index 27d7f2812972..53c1031fe357 100644
--- a/dev-php/PEAR-PEAR/ChangeLog
+++ b/dev-php/PEAR-PEAR/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/PEAR-PEAR
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/ChangeLog,v 1.85 2006/12/04 21:35:50 chtekk Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/ChangeLog,v 1.86 2007/03/20 19:22:59 chtekk Exp $
+
+*PEAR-PEAR-1.5.1 (20 Mar 2007)
+
+ 20 Mar 2007; Luca Longinotti <chtekk@gentoo.org> PEAR-PEAR-1.4.11.ebuild,
+ +PEAR-PEAR-1.5.1.ebuild:
+ Version bump, cleanup.
04 Dec 2006; Luca Longinotti <chtekk@gentoo.org> PEAR-PEAR-1.4.11.ebuild:
Add sandbox depend to avoid lots of bugreports due to users still having old
diff --git a/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.11.ebuild b/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.11.ebuild
index 8da646b1dfdf..33860d8df8da 100644
--- a/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.11.ebuild
+++ b/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.11.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.11.ebuild,v 1.14 2006/12/04 21:35:50 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.11.ebuild,v 1.15 2007/03/20 19:22:59 chtekk Exp $
inherit depend.php
ARCHIVE_TAR="1.3.1"
CONSOLE_GETOPT="1.2"
-PEAR="1.4.11"
XML_RPC="1.5.0"
+PEAR="1.4.11"
[[ -z "${PEAR_CACHEDIR}" ]] && PEAR_CACHEDIR="/var/cache/pear"
@@ -19,7 +19,6 @@ SRC_URI="http://pear.php.net/get/Archive_Tar-${ARCHIVE_TAR}.tgz
http://pear.php.net/get/Console_Getopt-${CONSOLE_GETOPT}.tgz
http://pear.php.net/get/XML_RPC-${XML_RPC}.tgz
http://pear.php.net/get/PEAR-${PEAR}.tgz"
-
LICENSE="PHP"
SLOT="0"
IUSE=""
@@ -71,28 +70,28 @@ src_install() {
# Prepare /usr/bin/pear script.
cp "${WORKDIR}/PEAR-${PEAR}/scripts/pearcmd.php" "${WORKDIR}/PEAR/pearcmd.php"
- sed -i "s:@pear_version@:${PEAR}:g" "${WORKDIR}/PEAR/pearcmd.php"
+ sed -i "s:@pear_version@:${PEAR}:g" "${WORKDIR}/PEAR/pearcmd.php" || die "sed failed"
cp "${WORKDIR}/PEAR-${PEAR}/scripts/pear.sh" "${WORKDIR}/PEAR/pear"
- sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/pear" || die
- sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/pear" || die
- sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/pear" || die
- sed -i "s:-d output_buffering=1:-d output_buffering=1 -d memory_limit=16M:g" "${WORKDIR}/PEAR/pear" || die
+ sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/pear" || die "sed failed"
+ sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/pear" || die "sed failed"
+ sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/pear" || die "sed failed"
+ sed -i "s:-d output_buffering=1:-d output_buffering=1 -d memory_limit=16M:g" "${WORKDIR}/PEAR/pear" || die "sed failed"
# Prepare /usr/bin/peardev script.
cp "${WORKDIR}/PEAR-${PEAR}/scripts/peardev.sh" "${WORKDIR}/PEAR/peardev"
- sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/peardev" || die
- sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/peardev" || die
- sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/peardev" || die
+ sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/peardev" || die "sed failed"
+ sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/peardev" || die "sed failed"
+ sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/peardev" || die "sed failed"
# Prepare /usr/bin/pecl script.
cp "${WORKDIR}/PEAR-${PEAR}/scripts/peclcmd.php" "${WORKDIR}/PEAR/peclcmd.php"
cp "${WORKDIR}/PEAR-${PEAR}/scripts/pecl.sh" "${WORKDIR}/PEAR/pecl"
- sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/pecl" || die
- sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/pecl" || die
- sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/pecl" || die
+ sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/pecl" || die "sed failed"
+ sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/pecl" || die "sed failed"
+ sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/pecl" || die "sed failed"
# Prepare PEAR/Dependency2.php.
- sed -i "s:@PEAR-VER@:${PEAR}:g" "${WORKDIR}/PEAR/PEAR/Dependency2.php" || die
+ sed -i "s:@PEAR-VER@:${PEAR}:g" "${WORKDIR}/PEAR/PEAR/Dependency2.php" || die "sed failed"
# Install Archive_Tar Package.
cp -r "${WORKDIR}/Archive_Tar-${ARCHIVE_TAR}/Archive" "${WORKDIR}/PEAR/Archive"
@@ -112,8 +111,8 @@ src_install() {
insinto /etc
doins "${FILESDIR}/pear.conf"
- sed -e "s|s:PHPCLILEN:\"PHPCLI\"|s:${#PHPCLI}:\"${PHPCLI}\"|g" -i "${D}/etc/pear.conf"
- sed -e "s|s:CACHEDIRLEN:\"CACHEDIR\"|s:${#PEAR_CACHEDIR}:\"${PEAR_CACHEDIR}\"|g" -i "${D}/etc/pear.conf"
+ sed -e "s|s:PHPCLILEN:\"PHPCLI\"|s:${#PHPCLI}:\"${PHPCLI}\"|g" -i "${D}/etc/pear.conf" || die "sed failed"
+ sed -e "s|s:CACHEDIRLEN:\"CACHEDIR\"|s:${#PEAR_CACHEDIR}:\"${PEAR_CACHEDIR}\"|g" -i "${D}/etc/pear.conf" || die "sed failed"
keepdir "${PEAR_CACHEDIR}"
fperms 755 "${PEAR_CACHEDIR}"
diff --git a/dev-php/PEAR-PEAR/PEAR-PEAR-1.5.1.ebuild b/dev-php/PEAR-PEAR/PEAR-PEAR-1.5.1.ebuild
new file mode 100644
index 000000000000..00160081d74f
--- /dev/null
+++ b/dev-php/PEAR-PEAR/PEAR-PEAR-1.5.1.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/PEAR-PEAR-1.5.1.ebuild,v 1.1 2007/03/20 19:22:59 chtekk Exp $
+
+inherit depend.php
+
+ARCHIVE_TAR="1.3.2"
+CONSOLE_GETOPT="1.2.2"
+STRUCTURES_GRAPH="1.0.2"
+XML_RPC="1.5.1"
+PEAR="1.5.1"
+
+[[ -z "${PEAR_CACHEDIR}" ]] && PEAR_CACHEDIR="/var/cache/pear"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="PEAR Base System (PEAR, Archive_Tar, Console_Getopt, Structures_Graph, XML_RPC)."
+HOMEPAGE="http://pear.php.net/"
+SRC_URI="http://pear.php.net/get/Archive_Tar-${ARCHIVE_TAR}.tgz
+ http://pear.php.net/get/Console_Getopt-${CONSOLE_GETOPT}.tgz
+ http://pear.php.net/get/Structures_Graph-${STRUCTURES_GRAPH}.tgz
+ http://pear.php.net/get/XML_RPC-${XML_RPC}.tgz
+ http://pear.php.net/get/PEAR-${PEAR}.tgz"
+LICENSE="PHP"
+SLOT="0"
+IUSE=""
+
+# we deliberately force people to remove their old PEAR installations,
+# and any package which may have put an old-style PEAR installation onto
+# their box
+# we also depend on a recent sandbox version to mitigate problems users
+# have been experiencing
+
+DEPEND="dev-lang/php
+ !dev-php/php
+ !dev-php/php-cgi
+ !dev-php/mod_php
+ !<dev-php/PEAR-PEAR-1.3.6-r2
+ !dev-php/PEAR-Archive_Tar
+ !dev-php/PEAR-Console_Getopt
+ !dev-php/PEAR-XML_RPC
+ >=sys-apps/sandbox-1.2.17"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ # we call this here, to ensure that the eclass picks the right
+ # version of php for the job
+ require_php_cli
+
+ # we check that PHP was compiled with the correct USE flags
+ if [[ ${PHP_VERSION} == "4" ]] ; then
+ require_php_with_use cli pcre expat zlib
+ else
+ require_php_with_use cli pcre xml zlib
+ fi
+}
+
+src_install() {
+ require_php_cli
+
+ # Prevent SNMP related sandbox violoation.
+ addpredict /usr/share/snmp/mibs/.index
+ addpredict /var/lib/net-snmp/
+
+ mkdir -p "${WORKDIR}/PEAR/XML/RPC"
+
+ # Install PEAR Package.
+ cp -r "${WORKDIR}/PEAR-${PEAR}/OS" "${WORKDIR}/PEAR/"
+ cp -r "${WORKDIR}/PEAR-${PEAR}/PEAR" "${WORKDIR}/PEAR/"
+ cp "${WORKDIR}/PEAR-${PEAR}/PEAR.php" "${WORKDIR}/PEAR/PEAR.php"
+ cp "${WORKDIR}/PEAR-${PEAR}/System.php" "${WORKDIR}/PEAR/System.php"
+
+ # Prepare /usr/bin/pear script.
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/pearcmd.php" "${WORKDIR}/PEAR/pearcmd.php"
+ sed -i "s:@pear_version@:${PEAR}:g" "${WORKDIR}/PEAR/pearcmd.php" || die "sed failed"
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/pear.sh" "${WORKDIR}/PEAR/pear"
+ sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/pear" || die "sed failed"
+ sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/pear" || die "sed failed"
+ sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/pear" || die "sed failed"
+ sed -i "s:-d output_buffering=1:-d output_buffering=1 -d memory_limit=32M:g" "${WORKDIR}/PEAR/pear" || die "sed failed"
+
+ # Prepare /usr/bin/peardev script.
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/peardev.sh" "${WORKDIR}/PEAR/peardev"
+ sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/peardev" || die "sed failed"
+ sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/peardev" || die "sed failed"
+ sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/peardev" || die "sed failed"
+
+ # Prepare /usr/bin/pecl script.
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/peclcmd.php" "${WORKDIR}/PEAR/peclcmd.php"
+ sed -i "s:@pear_version@:${PEAR}:g" "${WORKDIR}/PEAR/peclcmd.php" || die "sed failed"
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/pecl.sh" "${WORKDIR}/PEAR/pecl"
+ sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/pecl" || die "sed failed"
+ sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/pecl" || die "sed failed"
+ sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/pecl" || die "sed failed"
+
+ # Prepare PEAR/Dependency2.php.
+ sed -i "s:@PEAR-VER@:${PEAR}:g" "${WORKDIR}/PEAR/PEAR/Dependency2.php" || die "sed failed"
+
+ # Install Archive_Tar Package.
+ cp -r "${WORKDIR}/Archive_Tar-${ARCHIVE_TAR}/Archive" "${WORKDIR}/PEAR/"
+
+ # Install Console_Getopt Package.
+ cp -r "${WORKDIR}/Console_Getopt-${CONSOLE_GETOPT}/Console" "${WORKDIR}/PEAR/"
+
+ # Install Structures_Graph Package.
+ cp -r "${WORKDIR}/Structures_Graph-${STRUCTURES_GRAPH}/Structures" "${WORKDIR}/PEAR/"
+
+ # Install XML_RPC Package.
+ cp "${WORKDIR}/XML_RPC-${XML_RPC}/RPC.php" "${WORKDIR}/PEAR/XML/RPC.php"
+ cp "${WORKDIR}/XML_RPC-${XML_RPC}/Server.php" "${WORKDIR}/PEAR/XML/RPC/Server.php"
+
+ # Finalize installation.
+ cd "${WORKDIR}/PEAR"
+ insinto /usr/share/php
+ doins -r Archive Console OS PEAR Structures XML *.php
+ dobin pear peardev pecl
+
+ insinto /etc
+ doins "${FILESDIR}/pear.conf"
+ sed -e "s|s:PHPCLILEN:\"PHPCLI\"|s:${#PHPCLI}:\"${PHPCLI}\"|g" -i "${D}/etc/pear.conf" || die "sed failed"
+ sed -e "s|s:CACHEDIRLEN:\"CACHEDIR\"|s:${#PEAR_CACHEDIR}:\"${PEAR_CACHEDIR}\"|g" -i "${D}/etc/pear.conf" || die "sed failed"
+
+ keepdir "${PEAR_CACHEDIR}"
+ fperms 755 "${PEAR_CACHEDIR}"
+}
+
+pkg_preinst() {
+ rm -f "${ROOT}/etc/pear.conf"
+}
+
+pkg_postinst() {
+ if has_version "<dev-php/PEAR-PEAR-1.3.6-r2" ; then
+ ewarn "The location of the local PEAR repository has been changed"
+ ewarn "from /usr/lib/php to /usr/share/php."
+ fi
+
+ pear clear-cache
+
+ # Update PEAR/PECL channels as needed, add new ones to the list if needed
+ pearchans="pear.php.net pecl.php.net components.ez.no pear.phpdb.org pear.phing.info pear.symfony-project.com pear.phpunit.de pear.php-baustelle.de"
+
+ for chan in ${pearchans} ; do
+ pear channel-discover ${chan}
+ pear channel-update ${chan}
+ done
+}
diff --git a/dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.5.1 b/dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.5.1
new file mode 100644
index 000000000000..2e4e211fbe7f
--- /dev/null
+++ b/dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.5.1
@@ -0,0 +1,15 @@
+MD5 17d49e837b64df4e8f9124f829b22cd1 Archive_Tar-1.3.2.tgz 17150
+RMD160 cec105d1cdefd502f209c24c217645cec723d7a2 Archive_Tar-1.3.2.tgz 17150
+SHA256 952820c055a770a6d1ecdff487b3de0ff0617a1baca084dac443a6d5f7cde53c Archive_Tar-1.3.2.tgz 17150
+MD5 88ac4fc1bf4e3b25c04198e19e9412e9 Console_Getopt-1.2.2.tgz 4252
+RMD160 fb8a955ef2c41618305e03c9a4164c3a465c5e86 Console_Getopt-1.2.2.tgz 4252
+SHA256 880bcaf960b8ce085709b749e9b4f523bbc9bbe9a9e9dd908e06e5f55a113336 Console_Getopt-1.2.2.tgz 4252
+MD5 7d4b4d79f52cc03697ee2d2945a3b5f4 PEAR-1.5.1.tgz 290252
+RMD160 b1c7dc5d89d63a5d90e38527caca8a4bca93770c PEAR-1.5.1.tgz 290252
+SHA256 0d1c448225f449289c77cda87052f105efb711ccf7757df94d85f6a7c8c36a93 PEAR-1.5.1.tgz 290252
+MD5 2664e2d024048f982e12fad4d1bfbb87 Structures_Graph-1.0.2.tgz 30947
+RMD160 8eb53f6da109b90bab5d8101e99183a1ae116404 Structures_Graph-1.0.2.tgz 30947
+SHA256 d30e72fcb888d17d01d211dd0cdc8bdde8c87554fc4d7de438a4cf0b490a8697 Structures_Graph-1.0.2.tgz 30947
+MD5 1b516162ad65971b5fd04a7c279627ec XML_RPC-1.5.1.tgz 32215
+RMD160 6e8b9f4698285609d9c9d4450c59c16083607ee8 XML_RPC-1.5.1.tgz 32215
+SHA256 a5b517eef799df148d6c85ab19e188715a22c069f4507dcb792e5efb7d0f117e XML_RPC-1.5.1.tgz 32215