summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/php-cgi/php-cgi-5.0.1.ebuild')
-rw-r--r--dev-php/php-cgi/php-cgi-5.0.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-php/php-cgi/php-cgi-5.0.1.ebuild b/dev-php/php-cgi/php-cgi-5.0.1.ebuild
new file mode 100644
index 000000000000..dde9f38c2f23
--- /dev/null
+++ b/dev-php/php-cgi/php-cgi-5.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-5.0.1.ebuild,v 1.1 2004/08/13 21:42:27 robbat2 Exp $
+
+PHPSAPI="cgi"
+MY_P="php-${PV}"
+
+inherit php5-sapi eutils
+
+DESCRIPTION="PHP CGI"
+SLOT="0"
+KEYWORDS="~x86"
+
+# provides all base PHP extras (eg PEAR, extension building stuff)
+DEPEND_PHP=">=${PHP_PROVIDER_PKG}-5.0.0-r1"
+DEPEND="${DEPEND} ${DEPEND_PHP}"
+RDEPEND="${RDEPEND} ${DEPEND_PHP}"
+
+PROVIDE="virtual/php-${PV} virtual/httpd-php-${PV}"
+
+src_compile() {
+ # CLI needed to build stuff
+ my_conf="${my_conf} \
+ --enable-cgi \
+ --enable-cli \
+ --enable-fastcgi"
+
+ php5-sapi_src_compile
+}
+
+
+src_install() {
+ PHP_INSTALLTARGETS="install"
+ php5-sapi_src_install
+
+ # rename binary
+ mv ${D}/usr/bin/php ${D}/usr/bin/php-cgi
+}
+
+pkg_postinst() {
+ einfo "This is a CGI only build."
+}