summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/graph-tool/graph-tool-9999.ebuild')
-rw-r--r--dev-python/graph-tool/graph-tool-9999.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/dev-python/graph-tool/graph-tool-9999.ebuild b/dev-python/graph-tool/graph-tool-9999.ebuild
index 9086fa954808..9f020f3f47a4 100644
--- a/dev-python/graph-tool/graph-tool-9999.ebuild
+++ b/dev-python/graph-tool/graph-tool-9999.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/graph-tool/graph-tool-9999.ebuild,v 1.9 2015/01/14 03:43:42 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/graph-tool/graph-tool-9999.ebuild,v 1.10 2015/01/17 14:03:07 radhermit Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit check-reqs eutils toolchain-funcs python-r1
+inherit check-reqs toolchain-funcs python-r1
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.skewed.de/graph-tool"
- inherit git-2
+ EGIT_REPO_URI="https://github.com/count0/graph-tool.git"
+ inherit autotools git-r3
else
SRC_URI="http://downloads.skewed.de/${PN}/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
@@ -45,19 +45,20 @@ MAKEOPTS="${MAKEOPTS} -j1"
CHECKREQS_DISK_BUILD="6G"
pkg_pretend() {
- if use openmp; then
+ if use openmp ; then
tc-has-openmp || die "Please switch to an openmp compatible compiler"
fi
check-reqs_pkg_pretend
}
src_prepare() {
+ [[ ${PV} == "9999" ]] && eautoreconf
>py-compile
python_copy_sources
}
src_configure() {
- python_parallel_foreach_impl run_in_build_dir \
+ python_foreach_impl run_in_build_dir \
econf \
--disable-static \
--disable-optimization \
@@ -66,11 +67,11 @@ src_configure() {
}
src_compile() {
- python_parallel_foreach_impl run_in_build_dir default
+ python_foreach_impl run_in_build_dir default
}
src_install() {
- python_parallel_foreach_impl run_in_build_dir default
+ python_foreach_impl run_in_build_dir default
prune_libtool_files --modules
# remove unwanted extra docs