summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ipy/ipy-0.76-r1.ebuild')
-rw-r--r--dev-python/ipy/ipy-0.76-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/ipy/ipy-0.76-r1.ebuild b/dev-python/ipy/ipy-0.76-r1.ebuild
index 6a6c950936d7..b4ac0c530caa 100644
--- a/dev-python/ipy/ipy-0.76-r1.ebuild
+++ b/dev-python/ipy/ipy-0.76-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ipy-0.76-r1.ebuild,v 1.3 2013/04/06 15:25:21 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ipy-0.76-r1.ebuild,v 1.4 2013/04/06 15:33:37 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
@@ -29,7 +29,8 @@ DOCS=( ChangeLog README )
python_test() {
# doctests for py3 unaltered read py2 files from "${S}" causing total failure
cp -r test_doc.py README test "${BUILD_DIR}" || die
- cd "${BUILD_DIR}" || die
+ pushd "${BUILD_DIR}" > /dev/null || die
"${PYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
"${PYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
+ popd > /dev/null || die
}