summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyds/pyds-0.6.5.ebuild')
-rw-r--r--dev-python/pyds/pyds-0.6.5.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/dev-python/pyds/pyds-0.6.5.ebuild b/dev-python/pyds/pyds-0.6.5.ebuild
index fbed58ce3745..038c7b236279 100644
--- a/dev-python/pyds/pyds-0.6.5.ebuild
+++ b/dev-python/pyds/pyds-0.6.5.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyds/pyds-0.6.5.ebuild,v 1.1 2004/01/03 03:16:10 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyds/pyds-0.6.5.ebuild,v 1.1.1.1 2005/11/30 10:10:08 chriswhite Exp $
-inherit distutils
+inherit distutils eutils
MY_P="PyDS-${PV}"
@@ -10,9 +10,9 @@ DESCRIPTION="Python Desktop Server"
HOMEPAGE="http://pyds.muensterland.org/"
SRC_URI="http://simon.bofh.ms/~gb/${MY_P}.tar.gz"
-KEYWORDS="~x86"
SLOT="0"
-LICENSE="GPL-2"
+KEYWORDS="x86"
+LICENSE="MIT"
IUSE=""
RDEPEND="media-libs/jpeg
@@ -20,11 +20,17 @@ RDEPEND="media-libs/jpeg
>=dev-lang/python-2.2.2
>=dev-python/medusa-0.5.4
>=dev-db/metakit-2.4.9.2
- >=dev-python/Cheetah-0.9.15
+ >=dev-python/cheetah-0.9.15
>=dev-python/pyxml-0.8.2
>=dev-python/pyrex-0.5
>=dev-python/docutils-0.3
- >=dev-python/Imaging-1.1.3
+ >=dev-python/imaging-1.1.3
>=dev-python/soappy-0.10.1"
S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/PyDS
+ epatch ${FILESDIR}/${P}-py2.3.patch
+}