summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pythondialog/pythondialog-2.7-r1.ebuild')
-rw-r--r--dev-python/pythondialog/pythondialog-2.7-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pythondialog/pythondialog-2.7-r1.ebuild b/dev-python/pythondialog/pythondialog-2.7-r1.ebuild
new file mode 100644
index 000000000000..346c4d38d09f
--- /dev/null
+++ b/dev-python/pythondialog/pythondialog-2.7-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythondialog/pythondialog-2.7-r1.ebuild,v 1.1 2014/03/28 07:05:15 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python module for making simple text/console-mode user interfaces."
+HOMEPAGE="http://pythondialog.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pythondialog/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-util/dialog"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ sed -e "/^prefix=/d" -i setup.cfg || die "sed failed"
+ distutils-r1_python_prepare_all
+}