summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/visual')
-rw-r--r--dev-python/visual/ChangeLog8
-rw-r--r--dev-python/visual/files/visual-3.2.9-gcc43.patch11
-rw-r--r--dev-python/visual/visual-3.2.9-r2.ebuild78
3 files changed, 96 insertions, 1 deletions
diff --git a/dev-python/visual/ChangeLog b/dev-python/visual/ChangeLog
index 26be3aac0fbe..e39c87dd1508 100644
--- a/dev-python/visual/ChangeLog
+++ b/dev-python/visual/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/visual
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/ChangeLog,v 1.24 2009/01/08 21:39:15 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/ChangeLog,v 1.25 2009/02/03 17:59:47 patrick Exp $
+
+*visual-3.2.9-r2 (03 Feb 2009)
+
+ 03 Feb 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/visual-3.2.9-gcc43.patch, +visual-3.2.9-r2.ebuild:
+ gcc 4.3 fix, closes bug #237421. Patch from Nikolay Orlyuk
08 Jan 2009; Patrick Lauer <patrick@gentoo.org> -visual-4_beta0.ebuild:
Removing old
diff --git a/dev-python/visual/files/visual-3.2.9-gcc43.patch b/dev-python/visual/files/visual-3.2.9-gcc43.patch
new file mode 100644
index 000000000000..aba6a0253eac
--- /dev/null
+++ b/dev-python/visual/files/visual-3.2.9-gcc43.patch
@@ -0,0 +1,11 @@
+--- visual-3.2.9/include/platlinux.h.orig 2008-10-12 13:08:26.000000000 +0300
++++ visual-3.2.9/include/platlinux.h 2008-10-12 13:08:29.000000000 +0300
+@@ -24,7 +24,7 @@
+ pthread_mutex_t mtx;
+
+ public:
+- typedef lock<mutex> lock;
++ typedef ::visual::lock<mutex> lock;
+
+ mutex(int spincount=0, int count=1);
+ ~mutex();
diff --git a/dev-python/visual/visual-3.2.9-r2.ebuild b/dev-python/visual/visual-3.2.9-r2.ebuild
new file mode 100644
index 000000000000..25b598eb87eb
--- /dev/null
+++ b/dev-python/visual/visual-3.2.9-r2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/visual-3.2.9-r2.ebuild,v 1.1 2009/02/03 17:59:47 patrick Exp $
+
+inherit distutils
+
+DESCRIPTION="An easy to use Real-time 3D graphics library for Python."
+SRC_URI="http://www.vpython.org/download/${P}.tar.bz2"
+HOMEPAGE="http://www.vpython.org/"
+
+IUSE="doc examples numeric numarray"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+LICENSE="visual"
+
+RDEPEND="virtual/python
+ virtual/opengl
+ =x11-libs/gtk+-1.2*
+ =x11-libs/gtkglarea-1.2*
+ >=dev-libs/boost-1.31
+ numeric? ( dev-python/numeric )
+ numarray? ( >=dev-python/numarray-1.0 )
+ !numeric? ( !numarray? ( dev-python/numeric ) )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"/site-packages
+ epatch "${FILESDIR}/${P}"-import_bug143237.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${P}"-gcc43.patch
+}
+
+src_compile() {
+ local myconf="--without-numarray --without-numeric"
+
+ echo
+ if useq numeric; then
+ elog "Building with Numeric support"
+ myconf=${myconf/--without-numeric}
+ fi
+ if useq numarray; then
+ elog "Building with Numarray support"
+ myconf=${myconf/--without-numarray}
+ fi
+ if ! useq numeric && ! useq numarray; then
+ elog "Support for Numeric or Numarray was not specified."
+ elog "Building with Numeric support"
+ myconf=${myconf/--without-numeric}
+ fi
+ echo
+
+ econf \
+ --with-html-dir=/usr/share/doc/${PF}/html \
+ --with-example-dir=/usr/share/doc/${PF}/examples \
+ $(use_enable doc docs ) \
+ $(use_enable examples ) \
+ ${myconf} \
+ || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ python_version
+
+ insinto $(python_get_sitedir)
+ doins -r "${WORKDIR}/${P}"/site-packages/*
+
+ #the vpython script does not work, and is unnecessary.
+ #Also nuke directories that are empty so we don't have
+ #empty directories hanging around.
+ rm -rf "${D}"/usr/bin/
+
+}