summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wxPython/files/noglcanvas.diff')
-rw-r--r--dev-python/wxPython/files/noglcanvas.diff93
1 files changed, 0 insertions, 93 deletions
diff --git a/dev-python/wxPython/files/noglcanvas.diff b/dev-python/wxPython/files/noglcanvas.diff
deleted file mode 100644
index cfd4ebff7838..000000000000
--- a/dev-python/wxPython/files/noglcanvas.diff
+++ /dev/null
@@ -1,93 +0,0 @@
-diff -urN wxPython-2.3.2.1/setup.py wxPython-2.3.2.1-modified/setup.py
---- wxPython-2.3.2.1/setup.py Thu Dec 20 11:33:42 2001
-+++ wxPython-2.3.2.1-modified/setup.py Thu Aug 22 14:04:04 2002
-@@ -28,7 +28,7 @@
- """
-
-
--BUILD_GLCANVAS = 1 # If true, build the contrib/glcanvas extension module
-+BUILD_GLCANVAS = 0 # If true, build the contrib/glcanvas extension module
- BUILD_OGL = 1 # If true, build the contrib/ogl extension module
- BUILD_STC = 1 # If true, build the contrib/stc extension module
- BUILD_XRC = 1 # XML based resource system
-@@ -435,43 +435,43 @@
- #----------------------------------------------------------------------
- # Define the GLCanvas extension module
- #----------------------------------------------------------------------
--
--CTRB_SRC = opj(WXDIR, 'contrib/src')
--CTRB_INC = opj(WXDIR, 'contrib/include/wx')
--
--if BUILD_GLCANVAS or GL_ONLY:
-- msg('Preparing GLCANVAS...')
-- location = 'contrib/glcanvas'
-- swig_files = ['glcanvas.i']
-- other_sources = []
--
-- swig_sources = run_swig(swig_files, location, GENDIR, PKGDIR,
-- USE_SWIG, swig_force, swig_args)
--
-- gl_libs = []
-- if os.name == 'posix':
-- gl_config = os.popen(WX_CONFIG + ' --gl-libs', 'r').read()[:-1]
-- gl_lflags = string.split(gl_config) + lflags
-- gl_libs = libs
-- else:
-- other_sources = [opj(location, 'msw/myglcanvas.cpp')]
-- gl_libs = libs + ['opengl32', 'glu32']
-- gl_lflags = lflags
--
-- ext = Extension('glcanvasc',
-- swig_sources + other_sources,
--
-- include_dirs = includes,
-- define_macros = defines,
--
-- library_dirs = libdirs,
-- libraries = gl_libs,
--
-- extra_compile_args = cflags,
-- extra_link_args = gl_lflags,
-- )
--
-- wxpExtensions.append(ext)
-+#
-+#CTRB_SRC = opj(WXDIR, 'contrib/src')
-+#CTRB_INC = opj(WXDIR, 'contrib/include/wx')
-+#
-+#if BUILD_GLCANVAS or GL_ONLY:
-+# msg('Preparing GLCANVAS...')
-+# location = 'contrib/glcanvas'
-+# swig_files = ['glcanvas.i']
-+# other_sources = []
-+#
-+# swig_sources = run_swig(swig_files, location, GENDIR, PKGDIR,
-+# USE_SWIG, swig_force, swig_args)
-+#
-+# gl_libs = []
-+# if os.name == 'posix':
-+# gl_config = os.popen(WX_CONFIG + ' --gl-libs', 'r').read()[:-1]
-+# gl_lflags = string.split(gl_config) + lflags
-+# gl_libs = libs
-+# else:
-+# other_sources = [opj(location, 'msw/myglcanvas.cpp')]
-+# gl_libs = libs + ['opengl32', 'glu32']
-+# gl_lflags = lflags
-+#
-+# ext = Extension('glcanvasc',
-+# swig_sources + other_sources,
-+#
-+# include_dirs = includes,
-+# define_macros = defines,
-+#
-+# library_dirs = libdirs,
-+# libraries = gl_libs,
-+#
-+# extra_compile_args = cflags,
-+# extra_link_args = gl_lflags,
-+# )
-+#
-+# wxpExtensions.append(ext)
-
-
- #----------------------------------------------------------------------