summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/activeresource/activeresource-3.1.11.ebuild')
-rw-r--r--dev-ruby/activeresource/activeresource-3.1.11.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-ruby/activeresource/activeresource-3.1.11.ebuild b/dev-ruby/activeresource/activeresource-3.1.11.ebuild
deleted file mode 100644
index 132e4530e1b2..000000000000
--- a/dev-ruby/activeresource/activeresource-3.1.11.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.1.11.ebuild,v 1.1 2013/02/11 20:47:10 graaff Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Think Active Record for web resources.."
-HOMEPAGE="http://rubyforge.org/projects/activeresource/"
-SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="3.1"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-rails-*/activeresource"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}"
-ruby_add_bdepend "
- test? (
- >=dev-ruby/mocha-0.9.5
- virtual/ruby-test-unit
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
-
- # Avoid test broken by security fixes.
- sed -i -e '/test_load_yaml_array/,/^ end/ s:^:#:' test/cases/base_test.rb || die
-}