summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/fxruby/fxruby-1.6.11.ebuild')
-rw-r--r--dev-ruby/fxruby/fxruby-1.6.11.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/fxruby/fxruby-1.6.11.ebuild b/dev-ruby/fxruby/fxruby-1.6.11.ebuild
new file mode 100644
index 000000000000..d5200da82a2a
--- /dev/null
+++ b/dev-ruby/fxruby/fxruby-1.6.11.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.6.11.ebuild,v 1.1 2007/04/18 19:26:03 mabi Exp $
+
+RUBY_BUG_145222=yes
+inherit ruby
+
+MY_P="FXRuby-${PV}"
+
+DESCRIPTION="Ruby language binding to the FOX GUI toolkit"
+HOMEPAGE="http://www.fxruby.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/19801/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1.6"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples doc"
+
+DEPEND="=x11-libs/fox-1.6*
+ >=x11-libs/fxscintilla-1.62-r1"
+USE_RUBY="ruby16 ruby18 ruby19"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i -e 's:libs, "fxscintilla":libs, "fxscintilla-1.6":g' \
+ ext/fox16/extconf.rb || die "sed error"
+ einfo "Avoid -O0 builds"
+ sed -i -e 's:-O0 -Iinclude:-Iinclude:g' \
+ ext/fox16/extconf.rb || die "Can't fix forced -O0"
+}