summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/narray/narray-0.5.8.ebuild')
-rw-r--r--dev-ruby/narray/narray-0.5.8.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/narray/narray-0.5.8.ebuild b/dev-ruby/narray/narray-0.5.8.ebuild
new file mode 100644
index 000000000000..2742e34b6086
--- /dev/null
+++ b/dev-ruby/narray/narray-0.5.8.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/narray-0.5.8.ebuild,v 1.1 2005/10/06 13:17:10 caleb Exp $
+
+DESCRIPTION="Numerical N-dimensional Array class"
+HOMEPAGE="http://www.ir.isas.ac.jp/~masa/ruby/index-e.html"
+SRC_URI="http://www.ir.isas.ac.jp/~masa/ruby/dist/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~alpha ~hppa ~mips ~ppc ~sparc ~x86 ~amd64"
+IUSE=""
+DEPEND="virtual/ruby"
+
+src_compile() {
+ ruby extconf.rb || die
+ emake || die
+}
+
+src_install() {
+ make exec_prefix=/usr DESTDIR=${D} install || die
+ dodoc ChangeLog README.* SPEC.*
+}