summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rdtool')
-rw-r--r--dev-ruby/rdtool/files/digest-rdtool-0.6.61
-rw-r--r--dev-ruby/rdtool/rdtool-0.6.6.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/rdtool/files/digest-rdtool-0.6.6 b/dev-ruby/rdtool/files/digest-rdtool-0.6.6
new file mode 100644
index 000000000000..51689b7bcd91
--- /dev/null
+++ b/dev-ruby/rdtool/files/digest-rdtool-0.6.6
@@ -0,0 +1 @@
+MD5 36faf95bd070d560cf752b095ad4ea21 rdtool-0.6.6.tar.gz
diff --git a/dev-ruby/rdtool/rdtool-0.6.6.ebuild b/dev-ruby/rdtool/rdtool-0.6.6.ebuild
new file mode 100644
index 000000000000..1ff00901a518
--- /dev/null
+++ b/dev-ruby/rdtool/rdtool-0.6.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdtool/rdtool-0.6.6.ebuild,v 1.1 2000/11/17 08:22:04 jerry Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Fast string scanning library for Ruby"
+SRC_URI="http://www2.pos.to/~tosh/ruby/rdtool/archive/${A}"
+HOMEPAGE="http://www2.pos.to/~tosh/ruby/rdtool/en/index.html"
+
+DEPEND=">=dev-lang/ruby-1.6.1
+ >=dev-ruby/racc-1.2.4
+ >=dev-ruby/strscan-0.5.8
+ >=dev-ruby/optparse-0.7.5"
+
+src_compile() {
+ cd ${S}
+ try ruby rdtoolconf.rb
+ try make
+}
+
+src_install () {
+ cd ${S}
+ chmod 755 rd2
+ dobin rd2
+
+ cd ${S}/rd
+ insinto /usr/lib/ruby/site_ruby/1.6/rd
+ doins dot.rd2rc *.rb
+}