summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/expect/expect-5.43.0-r1.ebuild')
-rw-r--r--dev-tcltk/expect/expect-5.43.0-r1.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/dev-tcltk/expect/expect-5.43.0-r1.ebuild b/dev-tcltk/expect/expect-5.43.0-r1.ebuild
index 66e2f54523c5..3494353aaf2b 100644
--- a/dev-tcltk/expect/expect-5.43.0-r1.ebuild
+++ b/dev-tcltk/expect/expect-5.43.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.43.0-r1.ebuild,v 1.2 2010/04/17 13:40:36 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.43.0-r1.ebuild,v 1.3 2010/04/23 10:44:12 jlec Exp $
EAPI="3"
@@ -14,11 +14,12 @@ SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
-IUSE="doc"
+IUSE="doc X"
# We need dejagnu for src_test, but dejagnu needs expect
# to compile/run, so we cant add dejagnu to DEPEND :/
-DEPEND=">=dev-lang/tk-8.2"
+DEPEND=">=dev-lang/tcl-8.2
+ X? ( >=dev-lang/tk-8.2 )"
RDEPEND="${DEPEND}"
NON_MICRO_V=${PN}-$(get_version_component_range 1-2)
@@ -61,13 +62,20 @@ src_prepare() {
src_configure() {
local myconf
local tcl_version
- tcl_version="$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)"
+ tcl_version="$(best_version dev-lang/tcl | cut -d- -f3 | cut -d. -f1,2)"
TCL_HDIR="${EPREFIX}/usr/$(get_libdir)/tcl${tcl_version}/include"
-
#configure needs to find the file tclConfig.sh is
myconf="--with-tcl=${EPREFIX}/usr/$(get_libdir) --with-tclinclude=${TCL_HDIR}"
- myconf="$myconf --with-tk=${EPREFIX}/usr/$(get_libdir)"
+ if use X ; then
+ #--with-x is enabled by default
+ #configure needs to find the file tkConfig.sh and tk.h
+ #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
+ myconf="$myconf --with-tk=/usr/$(get_libdir)"
+ else
+ #configure knows that tk depends on X so just disable X
+ myconf="$myconf --without-x"
+ fi
econf $myconf --enable-shared
}