summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/dot2tex/dot2tex-2.8.5.ebuild')
-rw-r--r--dev-tex/dot2tex/dot2tex-2.8.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-tex/dot2tex/dot2tex-2.8.5.ebuild b/dev-tex/dot2tex/dot2tex-2.8.5.ebuild
new file mode 100644
index 000000000000..23b4733d7948
--- /dev/null
+++ b/dev-tex/dot2tex/dot2tex-2.8.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/dot2tex/dot2tex-2.8.5.ebuild,v 1.1 2009/03/08 15:49:37 aballier Exp $
+
+inherit distutils
+
+DESCRIPTION="A Graphviz to LaTeX converter"
+HOMEPAGE="http://www.fauskes.net/code/dot2tex/"
+SRC_URI="http://dot2tex.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=">=dev-python/pyparsing-1.4.8
+ media-gfx/pydot
+ media-gfx/graphviz"
+
+DOCS="changelog.txt"
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ dohtml -r doc/*
+ dodoc doc/usage.{txt,pdf}
+ fi
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins examples/*
+ fi
+}