summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bzr')
-rw-r--r--dev-util/bzr/ChangeLog8
-rw-r--r--dev-util/bzr/bzr-0.9.ebuild75
-rw-r--r--dev-util/bzr/files/bzr-0.9-binary-diff.patch79
-rw-r--r--dev-util/bzr/files/digest-bzr-0.93
4 files changed, 164 insertions, 1 deletions
diff --git a/dev-util/bzr/ChangeLog b/dev-util/bzr/ChangeLog
index 817cfd779d02..003576a50c63 100644
--- a/dev-util/bzr/ChangeLog
+++ b/dev-util/bzr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/bzr
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/ChangeLog,v 1.17 2006/07/11 17:45:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/ChangeLog,v 1.18 2006/08/24 18:46:31 marienz Exp $
+
+*bzr-0.9 (24 Aug 2006)
+
+ 24 Aug 2006; Marien Zwart <marienz@gentoo.org>
+ +files/bzr-0.9-binary-diff.patch, +bzr-0.9.ebuild:
+ Version bump, closes bug #144312, thanks to Geoff Weber <janax99@yahoo.com>.
11 Jul 2006; Aron Griffis <agriffis@gentoo.org> bzr-0.8.2-r1.ebuild:
Mark 0.8.2-r1 ~ia64
diff --git a/dev-util/bzr/bzr-0.9.ebuild b/dev-util/bzr/bzr-0.9.ebuild
new file mode 100644
index 000000000000..4fa8a67a3b9b
--- /dev/null
+++ b/dev-util/bzr/bzr-0.9.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/bzr-0.9.ebuild,v 1.1 2006/08/24 18:46:31 marienz Exp $
+
+inherit distutils bash-completion elisp-common eutils
+
+DESCRIPTION="next generation distributed version control"
+HOMEPAGE="http://bazaar-vcs.org/"
+SRC_URI="http://bazaar-vcs.org/pkg/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~x86-fbsd"
+IUSE="emacs"
+
+DEPEND=">=dev-lang/python-2.4
+ dev-python/celementtree
+ emacs? ( virtual/emacs )
+ >=dev-python/paramiko-1.5"
+
+PYTHON_MODNAME="bzrlib"
+
+DOCS="HACKING NEWS NEWS.developers"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Make bzr work with recent versions of diffutils.
+ epatch "${FILESDIR}/${P}-binary-diff.patch"
+
+ # Install the manpage in /usr/share/man instead of /usr/man
+ epatch "${FILESDIR}/${PN}-0.8-fix-manpage-location.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use emacs; then
+ elisp-compile contrib/emacs/bzr-mode.el || die "Emacs modules failed!"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ if use emacs; then
+ insinto "${SITELISP}"
+ doins contrib/emacs/bzr-mode.el*
+ elisp-site-file-install "${FILESDIR}/70bzr-gentoo.el"
+ fi
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh/_bzr
+ dobashcompletion contrib/bash/bzr
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ use emacs && elisp-site-regen
+ bash-completion_pkg_postinst
+
+ einfo "If you just upgraded from a version of bzr older than 0.9"
+ einfo "you should rename your ~/.bazaar/branches.conf to locations.conf"
+ einfo "(see /usr/share/doc/${PF}/NEWS.gz)"
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ # regenerate site-gentoo if we are merged USE=emacs and unmerged
+ # USE=-emacs
+ has_version virtual/emacs && elisp-site-regen
+}
+
+src_test() {
+ "${python}" bzr --no-plugins selftest || die "bzr selftest failed"
+}
diff --git a/dev-util/bzr/files/bzr-0.9-binary-diff.patch b/dev-util/bzr/files/bzr-0.9-binary-diff.patch
new file mode 100644
index 000000000000..0c930677b30d
--- /dev/null
+++ b/dev-util/bzr/files/bzr-0.9-binary-diff.patch
@@ -0,0 +1,79 @@
+# Bazaar revision bundle v0.8
+#
+# message:
+# Make the tests pass with recent versions of diffutils.
+# committer: Marien Zwart <marienz@gentoo.org>
+# date: Thu 2006-08-24 20:01:44.809999943 +0200
+
+=== modified file bzrlib/diff.py // last-changed:marienz@gentoo.org-20060824174
+... 709-83cf7a51d41c69f8
+--- bzrlib/diff.py
++++ bzrlib/diff.py
+@@ -166,8 +166,9 @@
+ # 'diff' gives retcode == 2 for all sorts of errors
+ # one of those is 'Binary files differ'.
+ # Bad options could also be the problem.
+- # 'Binary files' is not a real error, so we suppress that error
+- m = re.match('^binary files.*differ$', first_line, re.I)
++ # 'Binary files' is not a real error, so we suppress that error.
++ # Starting with diffutils 2.8.4 the word "binary" was dropped.
++ m = re.match('^(binary )?files.*differ$', first_line, re.I)
+ if not m:
+ raise BzrError('external diff failed with exit code 2;'
+ ' command: %r' % (diffcmd,))
+
+=== modified file bzrlib/tests/test_diff.py
+--- bzrlib/tests/test_diff.py
++++ bzrlib/tests/test_diff.py
+@@ -111,7 +111,11 @@
+
+ def test_external_diff_binary(self):
+ lines = external_udiff_lines(['\x00foobar\n'], ['foo\x00bar\n'])
+- self.assertEqual(['Binary files old and new differ\n', '\n'], lines)
++ # Older versions of diffutils say "Binary files", newer
++ # versions just say "files".
++ self.assertContainsRe(lines[0],
++ '(Binary f|F)iles old and new differ\n')
++ self.assertEquals(lines[1:], ['\n'])
+
+ def test_no_external_diff(self):
+ """Check that NoDiff is raised when diff is not available"""
+
+# revision id: marienz@gentoo.org-20060824180144-b5b013e11e5709f4
+# sha1: fd7d1ad679b4fde74c2d5927d4bb67b0e7dc6bac
+# inventory sha1: 18333f103b8c13ac42673e56e272805790a275c5
+# parent ids:
+# marienz@gentoo.org-20060824174709-83cf7a51d41c69f8
+# base id: pqm@pqm.ubuntu.com-20060811102108-06a24f3a1d4e7d82
+# properties:
+# branch-nick: bzr.0.9
+
+# message:
+# Make external diff in binary mode work with recent versions of diffutils.
+# committer: Marien Zwart <marienz@gentoo.org>
+# date: Thu 2006-08-24 19:47:09.569000006 +0200
+
+=== modified file bzrlib/diff.py // encoding:base64
+LS0tIGJ6cmxpYi9kaWZmLnB5CisrKyBienJsaWIvZGlmZi5weQpAQCAtMTY2LDggKzE2Niw5IEBA
+CiAgICAgICAgICAgICAjICdkaWZmJyBnaXZlcyByZXRjb2RlID09IDIgZm9yIGFsbCBzb3J0cyBv
+ZiBlcnJvcnMKICAgICAgICAgICAgICMgb25lIG9mIHRob3NlIGlzICdCaW5hcnkgZmlsZXMgZGlm
+ZmVyJy4KICAgICAgICAgICAgICMgQmFkIG9wdGlvbnMgY291bGQgYWxzbyBiZSB0aGUgcHJvYmxl
+bS4KLSAgICAgICAgICAgICMgJ0JpbmFyeSBmaWxlcycgaXMgbm90IGEgcmVhbCBlcnJvciwgc28g
+d2Ugc3VwcHJlc3MgdGhhdCBlcnJvcgotICAgICAgICAgICAgbSA9IHJlLm1hdGNoKCdeYmluYXJ5
+IGZpbGVzLipkaWZmZXIkJywgZmlyc3RfbGluZSwgcmUuSSkKKyAgICAgICAgICAgICMgJ0JpbmFy
+eSBmaWxlcycgaXMgbm90IGEgcmVhbCBlcnJvciwgc28gd2Ugc3VwcHJlc3MgdGhhdCBlcnJvci4K
+KyAgICAgICAgICAgICMgU3RhcnRpbmcgd2l0aCBkaWZmdXRpbHMgMi44LjQgdGhlIHdvcmQgImJp
+bmFyeSIgd2FzIGRyb3BwZWQuCisgICAgICAgICAgICBtID0gcmUubWF0Y2goJ14oYmluYXJ5ICk/
+ZmlsZXMuKmRpZmZlciQnLCBmaXJzdF9saW5lLCByZS5JKQogICAgICAgICAgICAgaWYgbm90IG06
+CiAgICAgICAgICAgICAgICAgcmFpc2UgQnpyRXJyb3IoJ2V4dGVybmFsIGRpZmYgZmFpbGVkIHdp
+dGggZXhpdCBjb2RlIDI7JwogICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICcgY29tbWFu
+ZDogJXInICUgKGRpZmZjbWQsKSkKCg==
+
+# revision id: marienz@gentoo.org-20060824174709-83cf7a51d41c69f8
+# sha1: a7a4000ddb2b723ba82c62a11104c4ed354abe13
+# inventory sha1: 03cc983b5e08ffbcdbb02fba0f4733c973d0a554
+# parent ids:
+# pqm@pqm.ubuntu.com-20060811102108-06a24f3a1d4e7d82
+# properties:
+# branch-nick: bzr.0.9
+
diff --git a/dev-util/bzr/files/digest-bzr-0.9 b/dev-util/bzr/files/digest-bzr-0.9
new file mode 100644
index 000000000000..9b5d633fc3f4
--- /dev/null
+++ b/dev-util/bzr/files/digest-bzr-0.9
@@ -0,0 +1,3 @@
+MD5 46a3320a7830b13516bef084bb87d86c bzr-0.9.tar.gz 935724
+RMD160 e01328785bae9d275cc71311627a11edb5a89224 bzr-0.9.tar.gz 935724
+SHA256 a50ec64ee581d9ecfb0b87098398b3fbbe19c9bd55a7782f75fe7232d83fcf90 bzr-0.9.tar.gz 935724