summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/patchelf/patchelf-0.8.ebuild')
-rw-r--r--dev-util/patchelf/patchelf-0.8.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/patchelf/patchelf-0.8.ebuild b/dev-util/patchelf/patchelf-0.8.ebuild
new file mode 100644
index 000000000000..2327e997563b
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/patchelf/patchelf-0.8.ebuild,v 1.1 2014/05/01 13:44:11 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="http://nixos.org/patchelf.html"
+SRC_URI="http://releases.nixos.org/${PN}/${P}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE=""
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ rm src/elf.h || die
+ sed -e 's:-Werror::g' -i configure.ac || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=( --docdir="${EPREFIX}"/usr/share/doc/${PF} )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test -j1
+}