summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/tig/tig-1.2.1.ebuild')
-rw-r--r--dev-vcs/tig/tig-1.2.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-vcs/tig/tig-1.2.1.ebuild b/dev-vcs/tig/tig-1.2.1.ebuild
new file mode 100644
index 000000000000..5ecf19d503f8
--- /dev/null
+++ b/dev-vcs/tig/tig-1.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-1.2.1.ebuild,v 1.1 2013/08/26 05:05:14 radhermit Exp $
+
+EAPI=5
+
+inherit bash-completion-r1 toolchain-funcs
+
+DESCRIPTION="Tig: text mode interface for git"
+HOMEPAGE="http://jonas.nitro.dk/tig/"
+SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+CDEPEND="sys-libs/ncurses"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ dev-vcs/git"
+
+src_prepare() {
+ # pre-generated manpages are in the root directory
+ sed -i '/^MANDOC/s#doc/##g' Makefile || die
+}
+
+src_configure() {
+ econf CURSES_LIB="$($(tc-getPKG_CONFIG) --libs ncursesw)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dodoc BUGS NEWS
+ dohtml manual.html README.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+}