summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'eclass/gnustep-old.eclass')
-rw-r--r--eclass/gnustep-old.eclass28
1 files changed, 14 insertions, 14 deletions
diff --git a/eclass/gnustep-old.eclass b/eclass/gnustep-old.eclass
index 86e9eccb2497..f4a63eed50d2 100644
--- a/eclass/gnustep-old.eclass
+++ b/eclass/gnustep-old.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/gnustep-old.eclass,v 1.8 2005/07/06 20:23:20 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/gnustep-old.eclass,v 1.9 2005/07/11 15:08:06 swegener Exp $
DESCRIPTION="Based on the gnustep eclass."
@@ -37,7 +37,7 @@ egnustepmake() {
getsourcedir
addwrite /root/GNUstep/Defaults/.GNUstepDefaults.lck
- addpredict /root/GNUstep
+ addpredict /root/GNUstep
cd ${S}
@@ -73,7 +73,7 @@ egnustepmake() {
fi
fi
fi
-
+
if [ -f ./[mM]akefile -o -f ./GNUmakefile ] ; then
make \
HOME=$TMP/fakehome \
@@ -89,15 +89,15 @@ egnustepinstall() {
getsourcedir
addwrite /root/GNUstep/Defaults/.GNUstepDefaults.lck
- addpredict /root/GNUstep
+ addpredict /root/GNUstep
cd ${S}
-
+
if [ -f /usr/GNUstep/System/Makefiles/GNUstep.sh ] ; then
- source /usr/GNUstep/System/Makefiles/GNUstep.sh
- else
- die "gnustep-make not installed!"
- fi
+ source /usr/GNUstep/System/Makefiles/GNUstep.sh
+ else
+ die "gnustep-make not installed!"
+ fi
mkdir -p $TMP/fakehome/GNUstep
@@ -106,7 +106,7 @@ egnustepinstall() {
# Should all the roots point at GNUSTEP_SYSTEM_ROOT to force
# install?
# GNUSTEP_USER_ROOT must be GNUSTEP_SYSTEM_ROOT, some malformed
- # Makefiles install there.
+ # Makefiles install there.
if [ "${PN}" = "gnustep-base" ] || [ "${PN}" = "gnustep-gui" ] || [ "${PN}" = "gnustep-back" ] ; then
# for some reason, they need less tending to...
make \
@@ -115,12 +115,12 @@ egnustepinstall() {
GNUSTEP_INSTALLATION_DIR=${D}${GNUSTEP_SYSTEM_ROOT} \
INSTALL_ROOT_DIR=${D} \
install || die "einstall failed"
- else
+ else
make \
GNUSTEP_USER_ROOT=$TMP/fakehome/GNUstep \
HOME=$TMP/fakehome \
- GNUSTEP_INSTALLATION_DIR=${D}${GNUSTEP_SYSTEM_ROOT} \
- INSTALL_ROOT_DIR=${D} \
+ GNUSTEP_INSTALLATION_DIR=${D}${GNUSTEP_SYSTEM_ROOT} \
+ INSTALL_ROOT_DIR=${D} \
GNUSTEP_LOCAL_ROOT=${D}${GNUSTEP_LOCAL_ROOT} \
GNUSTEP_NETWORK_ROOT=${D}${GNUSTEP_NETWORK_ROOT} \
GNUSTEP_SYSTEM_ROOT=${D}${GNUSTEP_SYSTEM_ROOT} \
@@ -128,7 +128,7 @@ egnustepinstall() {
install || die "einstall failed"
fi
else
- die "no Makefile found"
+ die "no Makefile found"
fi
return 0
}