summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/gltron/gltron-0.70.ebuild')
-rw-r--r--games-action/gltron/gltron-0.70.ebuild22
1 files changed, 20 insertions, 2 deletions
diff --git a/games-action/gltron/gltron-0.70.ebuild b/games-action/gltron/gltron-0.70.ebuild
index 0daa48252401..c8ddae925921 100644
--- a/games-action/gltron/gltron-0.70.ebuild
+++ b/games-action/gltron/gltron-0.70.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70.ebuild,v 1.5 2005/05/31 16:16:32 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70.ebuild,v 1.6 2005/07/30 04:37:47 vapier Exp $
-inherit games
+inherit eutils games
DESCRIPTION="3d tron, just like the movie"
HOMEPAGE="http://gltron.sourceforge.net/"
@@ -21,6 +21,24 @@ DEPEND="virtual/x11
media-libs/sdl-mixer
media-libs/sdl-sound"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-configure.patch
+ epatch "${FILESDIR}"/${P}-prototypes.patch
+}
+
+src_compile() {
+ # warn/debug/profile just modify CFLAGS, they aren't
+ # real options, so don't utilize USE flags here
+ egamesconf \
+ --disable-warn \
+ --disable-debug \
+ --disable-profile \
+ || die
+ emake || die
+}
+
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc ChangeLog README