summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/briquolo/ChangeLog8
-rw-r--r--games-arcade/briquolo/briquolo-0.5.7.ebuild7
-rw-r--r--games-arcade/briquolo/files/briquolo-0.5.7-libpng14.patch31
3 files changed, 41 insertions, 5 deletions
diff --git a/games-arcade/briquolo/ChangeLog b/games-arcade/briquolo/ChangeLog
index 9351fe25557f..a804b1b9897f 100644
--- a/games-arcade/briquolo/ChangeLog
+++ b/games-arcade/briquolo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/briquolo
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/briquolo/ChangeLog,v 1.17 2009/10/25 12:58:17 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/briquolo/ChangeLog,v 1.18 2010/03/09 16:59:33 ssuominen Exp $
+
+ 09 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> briquolo-0.5.7.ebuild,
+ +files/briquolo-0.5.7-libpng14.patch:
+ Fix building with libpng14 wrt #308667 by Locke Shinseiko (Wizzleby).
25 Oct 2009; Markus Meier <maekke@gentoo.org> briquolo-0.5.7.ebuild:
amd64/x86 stable, bug #288808
diff --git a/games-arcade/briquolo/briquolo-0.5.7.ebuild b/games-arcade/briquolo/briquolo-0.5.7.ebuild
index cf3e8d78ce90..d9292d3613a4 100644
--- a/games-arcade/briquolo/briquolo-0.5.7.ebuild
+++ b/games-arcade/briquolo/briquolo-0.5.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/briquolo/briquolo-0.5.7.ebuild,v 1.2 2009/10/25 12:58:17 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/briquolo/briquolo-0.5.7.ebuild,v 1.3 2010/03/09 16:59:33 ssuominen Exp $
inherit eutils games
@@ -25,7 +25,8 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-libpng14.patch
# no thanks we'll take care of it.
sed -i \
-e '/^SUBDIRS/s/desktop//' \
diff --git a/games-arcade/briquolo/files/briquolo-0.5.7-libpng14.patch b/games-arcade/briquolo/files/briquolo-0.5.7-libpng14.patch
new file mode 100644
index 000000000000..d325bac02578
--- /dev/null
+++ b/games-arcade/briquolo/files/briquolo-0.5.7-libpng14.patch
@@ -0,0 +1,31 @@
+http://bugs.gentoo.org/show_bug.cgi?id=308667
+
+--- src/MOGL/MOGL_Image.cpp
++++ src/MOGL/MOGL_Image.cpp
+@@ -183,7 +183,7 @@ bool MOGL_Image::ChargerPNG(const char *
+ info_ptr = png_create_info_struct(png_ptr);
+ if (info_ptr == NULL)
+ {
+- png_destroy_read_struct(&png_ptr, png_infopp_NULL, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, NULL, NULL);
+ return false;
+ }
+
+@@ -191,7 +191,7 @@ bool MOGL_Image::ChargerPNG(const char *
+ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ // On libère la mémoire
+- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ return false;
+ }
+
+@@ -235,7 +235,7 @@ bool MOGL_Image::ChargerPNG(const char *
+ /* Expand grayscale images to the full 8 bits from 1, 2, or 4 bits/pixel */
+ if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
+ {
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ }
+
+ /* Expand paletted or RGB images with transparency to full alpha channels