summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/mah-jong/mah-jong-1.6.3.ebuild')
-rw-r--r--games-board/mah-jong/mah-jong-1.6.3.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/games-board/mah-jong/mah-jong-1.6.3.ebuild b/games-board/mah-jong/mah-jong-1.6.3.ebuild
index 52a9c6848ac8..d2fe7ed8db85 100644
--- a/games-board/mah-jong/mah-jong-1.6.3.ebuild
+++ b/games-board/mah-jong/mah-jong-1.6.3.ebuild
@@ -1,33 +1,33 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/mah-jong-1.6.3.ebuild,v 1.1 2004/05/10 02:17:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/mah-jong-1.6.3.ebuild,v 1.1.1.1 2005/11/30 10:10:00 chriswhite Exp $
inherit games
MY_P="mj-${PV}-src"
-S="${WORKDIR}/${MY_P}"
DESCRIPTION="A networked Mah Jong program, together with a computer player"
HOMEPAGE="http://www.stevens-bradfield.com/MahJong/"
SRC_URI="http://www.stevens-bradfield.com/MahJong/Source/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 amd64"
+KEYWORDS="amd64 ppc x86"
IUSE=""
RDEPEND="virtual/x11
=x11-libs/gtk+-1.2*"
DEPEND="${RDEPEND}
- dev-lang/perl
- >=sys-apps/sed-4"
+ dev-lang/perl"
+
+S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i \
-e '/^.TH/ s/1/6/' xmj.man \
- || die "sed xmj.man failed"
+ || die "sed xmj.man failed"
sed -i \
-e "/^DESTDIR =/ s:=.*:= ${D}:" \
-e "/^BINDIR =/ s:=.*:= ${GAMES_BINDIR}:" \
@@ -35,7 +35,7 @@ src_unpack() {
-e "/^MANSUFFIX =/ s:1:6:" \
-e "/^CFLAGS =/ s:=:= ${CFLAGS}:" \
-e "/^TILESETPATH=/ s:NULL:\"${GAMES_DATADIR}/${PN}/\":" Makefile \
- || die "sed Makefile failed"
+ || die "sed Makefile failed"
}
src_install() {
@@ -44,7 +44,7 @@ src_install() {
cp -R fallbacktiles/ \
tiles-numbered/ \
tiles-small/ "${D}${GAMES_DATADIR}/${PN}" \
- || die "cp failed"
+ || die "cp failed"
dodoc CHANGES ChangeLog *.txt
prepgamesdirs
}