summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/epsxe/epsxe-1.6.0-r3.ebuild')
-rw-r--r--games-emulation/epsxe/epsxe-1.6.0-r3.ebuild30
1 files changed, 13 insertions, 17 deletions
diff --git a/games-emulation/epsxe/epsxe-1.6.0-r3.ebuild b/games-emulation/epsxe/epsxe-1.6.0-r3.ebuild
index 75ab6f4f6217..86a9ecc2cdbb 100644
--- a/games-emulation/epsxe/epsxe-1.6.0-r3.ebuild
+++ b/games-emulation/epsxe/epsxe-1.6.0-r3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/epsxe/epsxe-1.6.0-r3.ebuild,v 1.9 2006/11/28 18:36:58 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/epsxe/epsxe-1.6.0-r3.ebuild,v 1.10 2007/02/24 00:16:13 nyhm Exp $
inherit games
-DESCRIPTION="ePSXe Playstation Emulator"
+DESCRIPTION="ePSXe PlayStation Emulator"
HOMEPAGE="http://www.epsxe.com/"
SRC_URI="http://www.epsxe.com/files/epsxe${PV//.}lin.zip"
@@ -12,20 +12,16 @@ LICENSE="freedist"
SLOT="0"
KEYWORDS="-* x86"
IUSE="opengl"
-RESTRICT="strip" # For some strange reason, strip truncates the whole file
+RESTRICT="strip"
-DEPEND="app-arch/unzip"
-RDEPEND=">=dev-libs/glib-1.2
- =x11-libs/gtk+-1.2*
- =sys-libs/ncurses-5*
- =sys-libs/zlib-1*
- net-misc/wget
+RDEPEND="=x11-libs/gtk+-1.2*"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+RDEPEND="${RDEPEND}
x11-misc/imake
games-emulation/psemu-peopsspu
- || (
- opengl? ( games-emulation/psemu-gpupetemesagl )
- games-emulation/psemu-peopssoftgpu
- )"
+ opengl? ( games-emulation/psemu-gpupetemesagl )
+ !opengl? ( games-emulation/psemu-peopssoftgpu )"
S=${WORKDIR}
@@ -35,13 +31,13 @@ src_install() {
sed -i \
-e "s:GAMES_PREFIX_OPT:${GAMES_PREFIX_OPT}:" \
-e "s:GAMES_LIBDIR:${GAMES_LIBDIR}:" \
- "${D}${GAMES_BINDIR}/epsxe" \
+ "${D}${GAMES_BINDIR}"/epsxe \
|| die "sed failed"
exeinto "${dir}"
- insinto "${dir}"
doexe epsxe || die "doexe failed"
+ insinto "${dir}"
doins keycodes.lst || die "doins failed"
- insinto "${GAMES_LIBDIR}/psemu/cheats"
+ insinto "${GAMES_LIBDIR}"/psemu/cheats
doins cheats/* || die "doins failed"
dodoc docs/*
prepgamesdirs