summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3.ebuild')
-rw-r--r--games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3.ebuild b/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3.ebuild
new file mode 100644
index 000000000000..9022eb6872b1
--- /dev/null
+++ b/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3.ebuild,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+inherit games
+
+DESCRIPTION="PSEmu2 CD/DVD plugin"
+HOMEPAGE="http://www.pcsx2.net/"
+SRC_URI="http://www.pcsx2.net/download/0.4release/CDVDlinuz-${PV}.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="=x11-libs/gtk+-1*"
+
+S=${WORKDIR}/CDVDlinuz
+
+src_unpack() {
+ unpack ${A}
+ tar -xf CDVDlinuz-${PV} || die "unpacking tar"
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-makefile.patch
+}
+
+src_compile() {
+ cd Src
+ emake OPTFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dodoc ReadMe.txt
+ cd Src
+ exeinto ${GAMES_LIBDIR}/ps2emu/plugins
+ doexe lib*
+ prepgamesdirs
+}