summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/ut2004-bonuspack-ece')
-rw-r--r--games-fps/ut2004-bonuspack-ece/ChangeLog9
-rw-r--r--games-fps/ut2004-bonuspack-ece/files/digest-ut2004-bonuspack-ece-1-r33
-rw-r--r--games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild70
3 files changed, 81 insertions, 1 deletions
diff --git a/games-fps/ut2004-bonuspack-ece/ChangeLog b/games-fps/ut2004-bonuspack-ece/ChangeLog
index d3040fd7b2f3..296a43780a86 100644
--- a/games-fps/ut2004-bonuspack-ece/ChangeLog
+++ b/games-fps/ut2004-bonuspack-ece/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-fps/ut2004-bonuspack-ece
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-bonuspack-ece/ChangeLog,v 1.12 2006/09/26 14:57:28 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-bonuspack-ece/ChangeLog,v 1.13 2006/11/07 19:26:23 wolf31o2 Exp $
+
+*ut2004-bonuspack-ece-1-r3 (07 Nov 2006)
+
+ 07 Nov 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +ut2004-bonuspack-ece-1-r3.ebuild:
+ Added new revision for testing which uses the brand-spankin-new
+ games-mods.eclass to reduce ebuild code.
26 Sep 2006; Chris Gianelloni <wolf31o2@gentoo.org>
ut2004-bonuspack-ece-1-r2.ebuild:
diff --git a/games-fps/ut2004-bonuspack-ece/files/digest-ut2004-bonuspack-ece-1-r3 b/games-fps/ut2004-bonuspack-ece/files/digest-ut2004-bonuspack-ece-1-r3
new file mode 100644
index 000000000000..38b19955bc69
--- /dev/null
+++ b/games-fps/ut2004-bonuspack-ece/files/digest-ut2004-bonuspack-ece-1-r3
@@ -0,0 +1,3 @@
+MD5 098be93d06823c5fd416fa701e83418f ut2004megapack-linux.tar.bz2 203124107
+RMD160 8a5fa450c0a5cb9c3a66c5996a2a92bff2a1302f ut2004megapack-linux.tar.bz2 203124107
+SHA256 b9122c8c405945d29c3cdf61f57fe4d21e886b79ea9caa0d8e0ca2e520aa472c ut2004megapack-linux.tar.bz2 203124107
diff --git a/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild b/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild
new file mode 100644
index 000000000000..010d20a598e5
--- /dev/null
+++ b/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild,v 1.1 2006/11/07 19:26:23 wolf31o2 Exp $
+
+MOD_DESC="Editor's Choice Edition bonus pack"
+MOD_NAME="Editor's Choice Edition"
+
+inherit games games-mods
+
+MY_P="ut2004megapack-linux.tar.bz2"
+
+HOMEPAGE="http://www.unrealtournament2004.com/"
+SRC_URI="mirror://3dgamers/unrealtourn2k4/Missions/${MY_P}
+ http://0day.icculus.org/ut2004/${MY_P}
+ ftp://ftp.games.skynet.be/pub/misc/${MY_P}
+ http://sonic-lux.net/data/mirror/ut2004/${MY_P}"
+
+LICENSE="ut2003"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="games-fps/ut2004-data"
+
+S=${WORKDIR}/UT2004MegaPack
+dir=${GAMES_PREFIX_OPT}/${GAME}
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ games_pkg_setup
+}
+
+src_unpack() {
+ games-mods_src_unpack
+ cd "${S}"
+ # Remove megapack files which are not in ece
+ rm Animations/ONSNewTank-A.ukx
+ rm Help/ReadMePatch.int.txt
+ # Help/{DebuggerLogo.bmp,InstallerLogo.bmp,Unreal.ico,UnrealEd.ico}
+ # are not in megapack.
+ # Keep new Help/UT2004Logo.bmp
+ # Manual dir does not exist in megapack
+ rm Maps/{AS*,CTF*,DM*}
+ rm Sounds/A_Announcer_BP2.uax
+ rm StaticMeshes/{JumpShipObjects.usx,Ty_RocketSMeshes.usx}
+ rm System/{A*,b*,B*,CacheRecords.ucl,*.det,*.est,*.frt,*.itt,*.kot}
+ rm System/{CTF*,D*,Editor*,G*,I*,L*,ONS-Arc*,Onslaught.*,*.md5}
+ rm System/{u*,U*,V*,X*,Core.u,Engine.u,F*,*.ucl,Sk*}
+ rm Textures/{J*,j*,T*}
+ rm -r Web
+
+ # The file lists of ut2004-3369-r1 and -r2 are identical
+ # Remove files owned by ut2004-3369-r2
+ rm Help/UT2004Logo.bmp
+ # The 2 Manifest files have not changed
+ rm System/{Manifest.in{i,t},OnslaughtFull.int}
+ rm System/{Core.int,Engine.int,Setup.int,Window.int}
+ rm System/{OnslaughtFull.u,OnslaughtBP.u}
+}
+
+src_install() {
+ # Install Editor's Choice Edition
+ for n in {Animations,Help,Maps,Sounds,StaticMeshes,System,Textures}
+ do
+ dodir "${dir}"/${n}
+ cp -r "${S}"/${n}/* "${Ddir}"/${n} \
+ || die "copying ${n} from Editor's Choice Edition"
+ done
+
+ prepgamesdirs
+}