summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild')
-rw-r--r--games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild32
1 files changed, 19 insertions, 13 deletions
diff --git a/games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild b/games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild
index a0a9ac7caf19..3e2d616f50f8 100644
--- a/games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild
+++ b/games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild
@@ -1,27 +1,33 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild,v 1.4 2009/10/01 22:18:22 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild,v 1.5 2009/10/09 01:39:46 nyhm Exp $
+
+EAPI=2
MOD_DESC="multiplayer driving mod focusing on fun driving"
-MOD_NAME="Unwheel"
+MOD_NAME="UnWheel"
MOD_DIR="unwheel"
-inherit versionator games games-mods
-
-MY_PV=$(get_version_component_range 2-2)
-MY_PV=${PV/0_beta/r}
-MY_PN="unwheel"
+inherit games games-mods
HOMEPAGE="http://unwheel.beyondunreal.com/"
-SRC_URI="mirror://beyondunreal/${MY_PN}/${MY_PN}_${MY_PV}.zip
- mirror://beyondunreal/${MY_PN}/packs/UnWheel-R5_BonusPack-Volume_1.zip"
+SRC_URI="unwheel_r5.zip
+ UnWheel-R5_BonusPack-Volume_1.zip"
-LICENSE="as-is"
+LICENSE="freedist"
KEYWORDS="amd64 x86"
IUSE="dedicated opengl"
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ elog "Please download the following files:"
+ elog "http://www.filefront.com/5110896"
+ elog "http://www.filefront.com/13792114"
+ elog "and move them to ${DISTDIR}"
+}
src_unpack() {
- mkdir -p ${MOD_DIR}
- unzip "${DISTDIR}"/${MY_PN}_${MY_PV}.zip -d ${MOD_DIR}
- unzip "${DISTDIR}"/UnWheel-R5_BonusPack-Volume_1.zip -d ${MOD_DIR}
+ mkdir ${MOD_DIR}
+ cd ${MOD_DIR}
+ unpack ${A}
}